Pi4 Audio Output

Does anyone know how to change the audio output to analogue? I think by default it goes through HDMI. I believe its done through the config.txt I just don’t remember the command. Any help would be appreciated.

I not sure what you are asking but if you want sound from the a/v jack on the board it has been a long time since I messed with it. You have to change in /boot/cmdline.txt “snd-bcm2835.enable_compat_alsa=0” to “snd-bcm2835.enable_compat_alsa=1” Then in the /boot/config.txt disable the line “hdmi_drive=2”. There may be something else you have to do but I do not remember. You will have to choose the output in PulseAudio Volume Control.

Thank you Darksky, Yes I meant a/v jack. I will give this a go. Just out of curiosity, why do you need to disable HDMI_drive=2. Would that stop video output to that port? Also are there ways you could enable audio output to either HDMI ports? Would be nice to have this added to the wiki.
Thank you!

I guess I am still not sure what you are wanting. Do you want sound through hdmi or the a/v port on the pi board?

This blocks sound from going through the hdmi port by disabling this line.



/boot config.txt:

hdmi port 0:


hdmi port 1:


Sorry I’m just trying to figure out all the ways I can configure audio outputs. Either through HDMI 1 or 2. Or through a/v port. Currently I’m trying to configure the a/v port.

Thank you once again for the quick replies and for your help!

There must be something that I’m missing. I’ve done all the changes in the config and cmdline and tried both output (playback) devices. A/v jack doesn’t seem to work.

What 2 output devices. I am still unclear what you are trying to do.

If you are trying the a/v output on the pi 4 some devices are wired different and are not compatible plugging in the hole. I wound up here using my android phone ear plugs before it would work. They sell an adapter to plug in which I did not have.

To change pulseaudio output, do you do it from audio volume settings? I can see two playback devices there.

In the Menu Sound: --> PulseAudio Volume Control

It may say Headphones.

Some times you have to remove ~/.config/pulse directory.

How do you get to Menu Sound? I found that if I go to system settings and audio tab. Maybe I’m not on same page.

What is the output of:

amixer controls

Enter this in a terminal then plug something in the pi4 onboard a/v jack:

sudo amixer cset numid=3 1
sudo amixer cset numid=3 50%

No luck unfortunately.

It should have worked. What are you trying to plug into the pi4 a/v jack?

I have asked you twice what you are plugging into the onboard 3.5 jack and have not gotten a response.

At this point I believe what you are plugging in has a stereo plug or something that is not compatible. You have to remember that there are multiple taps in the hole for audio and video. That is why they sell an adapter to separate the 2 formats. Some phone headphones will work as the have multiple taps on the plug and some are wired wrong.

Sorry just regular speakers. It worked on raspbian by switching output in raspi-config. Not sure why its not working here.

I set it up here and I switched to the headphones with the with the volume control on the taskbar in xfce. Also I included a pic of the PulseAudio control panel and you can switch there using the bottom Built-in Audio Stereo. The top one is the hdmi. You may have to turn the volume up when you switch.

I am not having any luck. I will post below the steps I have taken. I’m using the KDE desktop. I have tried another set of headphones as well. Does not seem to work either. I can confirm though port works on raspbian. I quickly booted raspbian on microsd to double check. I must be missing a parameter or something. I hope the pics below will show something.