PGP/GPG Key: "Unknown public Key"

Hi and yes I saw the main article on this, the forum won’t let me include a link, not even to itself. But the post was titled “AUR package fails to verify PGP/GPG jey…”
I had a group of five and it did help with some, but I have two left Spotify and compton-conf that even though it says the key import was successful it still fails with the same error. I also tried more than one key server and the message states the key was unchanged, so it was the same.

Any heko would be great, I hate getting behind on updates and this has been going on for a while.


Always check the AUR package comment section for tips. :wink:

Even if you cant include links … you could include what you’ve tried somewhere in that paragraph.

Then its been a while since you should have fixed it.
These are AUR packages. Are you familiar with how to manage the AUR? Specifically manually?

Have you seen the wiki?
Arch User Repository - Manjaro
Is this one of the threads you looked at?
Dropbox "One or more PGP signatures could not be verified"
What about the AUR page itself?
AUR (en) - spotify

Pinned Comments

NicoHood commented on 2020-05-27 07:46

The package has been flagged out of date again. I want to remind, that we package the stable version of spotify, not the testing version. Stable versions can be found under the following link and have not been updated for a long time:

You can fix the GPG key issue by using:

curl -sS | gpg --import -
1 Like

yes, it has been a while, I am also a developer on a different platform and rarely have a lot of time, no excuse though. I tried the Spotify fix and while it said the key was updated it failed the same way. So in the case of Spotify stable should I be running testing? And any ideas on the Compton-conf, which is the other one out of the five that didn’t seem to take the key update? I was able to get the others running fine.
The post I read originally the title was " AUR package fails to verify PGP/GPG key: “unknown public key”, “One or more PGP signatures could not be verified!” the forum won’t let me share a link.
I really appreciate your help with this, thanks

I went and read the AUR page for Manjaro, I followed the instructions, I also used the code above to import the key, still same error message. Any ideas? BTW compton-conf was solved with the AUR listing


Did you look more closely at that page, for example: