Dropbox "One or more PGP signatures could not be verified"

I’m installing Dropbox on a new computer via AUR, and getting a signature could not be verified error. I tried a few things, but it didn’t work. How can I fix this?

Here’s the entire message:
Verifying source file signatures with gpg…
dropbox-lnx.x86_64-104.4.175.tar.gz … FAILED (unknown public key FC918B335044912E)
==> ERROR: One or more PGP signatures could not be verified!

Follow the instructions provided in the pinned comment in the AUR page of dropbox here:

Run the mentioned command to import the key and then try to install the package again.

More information about the error you’re getting can be found here:

I received this error when I entered this key in the link:
gpg --recv-keys 1C61A2656FB57B7E4DE0F4C1FC918B335044912E

“gpg: keyserver receive failed: General error”

Use a different Keyserver. It is described on the same page that @bill_t already linked in the previous post.

1 Like

Same as here:

wget https://linux.dropbox.com/fedora/rpm-public-key.asc
gpg --import rpm-public-key.asc

Moving to AUR subcategory and removing kde flag

1 Like

That worked!
Thanks everyone,

Any idea as to why Manjaro doesn’t make the “dropbox” an official repository since it’ so common?

Dropbox inc. does not allow it. The company prevents redistribution of the client.

1 Like

Then how does KDE neon or Kubuntu get a way with it, as it’s available in discover?

Is it a flatpak version? You can install flatpak Dropbox on manjaro so maybe they use flatpak version

Dropbox was part of the community repo at some point, but was dropped to the AUR not only for the reason @xabbu mentioned above, but because it tries to auto-update by installing a binary in the user’s home directory.
See here the discussion:

More information on how to prevent automatic updates can be found in the Arch Wiki:


I’m clear now. That make sense. Thanks for the info.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.