Persistent error with bootable USB stick and the Plasma Desktop release

Hello!

I’m very new to Linux, and found Monjaro to be a solid starting point because I want to eventually get accustomed to arch. I’m having an error that has persisted over 3 separate USB sticks and 3 separate downloads (each verified sha1).

When I boot to the Start screen and select start with proprietary drivers, I get the following error:

# typed by hand since I cant upload an image:
starting version 251.2-3-manjaro
mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0

dmesg(1) may have more information after failed mount system call
ERROR: failed to mount '/dev/loop0'

I’ve searched the error above multiple times, but a lot of the answers go right over my head. Any help is greatly appreciated!

format the usb drive, then flash ventoy and copy the iso there and try again

1 Like

Just tried this with no luck, same error. Is it an issue with the iso itself? Should I grab another version, and if so, where?

you can download the latest from here
use ventoy, and boot the iso in bios mode if you are using bios, or uefi mode if you are using uefi
check if secure boot is disabled
and you said that it happens with proprietary drivers, so try open source instead

Awesome, thank you! Maybe a dumb question, but how do I specify BIOS vs UEFI? Is this something I need to set through Ventoy?

and do you have bios mode or uefi mode? when you selecting the usb to boot there are 2 options, one has uefi there and one has not, that means its in bios mode

I’m 90% sure that I’m on UEFI, but I’ll see if I can double check. Once I’m back on my PC I’ll try it again with the steps you provided, thanks!

Hey, welcome to the linux world. Wish you good luck.

What is Monjaro?

Oh? How did you find out that, since you are “very new”?

Wait, you haven’t even tried it yet? I can tell you right now that a good solid starting point is anything else but arch based distros.

Which solutions have you tried? (there is many regarding this very error)

Ah, ok. So why are you trying to skip steps and use distro that will sooner or later be over your head as well? Start with something for beginners like linux mint.

Well, that’s my suggestion at least.

Im following a tutorial to create a windows VM with a single gpu, and I chose manjaro since it’s what the tutorial is using. I also like what I’ve heard about arch, so I’m thinking it may be best for me to start with manjaro. I’m not fully sure, but I don’t think setup should be giving me this much trouble. Just trying to get it set up so I can start using it :slight_smile:

Ah, you are trying to install manjaro in virtual machine in windows? Virtualbox?

No, other way around. I want to use manjaro as my daily driver, and use KVM for windows 11 so I can still use my apps and games.

Then my points still stand.

You do realize that you need a second gpu to play games (with decent quality) in a vm?

Regardless, I just want to get Manjaro setup. Any help appreciated! :slight_smile:

Wait, these instructions are fine by you, but answers for a working live iso are over your head? :smiley:

Disable secure boot, enable uefi and/or use some other tool to copy image to usb.

Awesome, Thanks!

So I’ve verified that secure boot is disabled and UEFI is enabled. Tried linux mint with ventoy and was successful, but it only boots in comparability mode… In the normal mode, I’m only getting steaks on my screen.

Would it help to update my bios? Does it matter that I’m using a 5th gen ryzen with a 2000 series nvidia gpu?

Got one for lunch today, mmm.

Honestly, no idea. It should work without that. Can you try some other iso? Do you have another usb to try it? Without ventoy.

1 Like

Haha sorry for the typos, autocorrect is going bananas.

I’ve tried 3 unique usb sticks to no avail. Before I made the post I tried 3 iso burners with the same result.

I’m so lost as to why this isn’t working. :smiling_face_with_tear:

Should I change anything within the boot options on the main screen?

Now that I can post images, here is the full error message.

Well I don’t see how it’s anything other than either something in your bios settings or something with iso/usb/the process of copying to usb.