pCloud Drive does not work on Manjaro KDE

This is my first time on Manjaro Linux Forum. (I don’t remember even I had send a message to any Internet forum before.) So please be patient, if not doing everything right. I’m no IT professional.

I sent the following message to the pcloud support already. Because I’m not sure they can solve the issue, I send it also here, because I’d like to stay on Manjaro KDE and not to change to another distro. The solution might be something simple which I don’t know, for instance, about Manjaro.

The issue is as follows.

uname -a
Linux hi-vostro3360 5.10.102-1-MANJARO #1 SMP PREEMPT Wed Feb 23 14:44:40 UTC 2022 x86_64 GNU/Linux

fusermount -V
fusermount version: 2.9.9

When I choose ‘Open Drive’ from system tray of pCloud on Manjaro KDE, there are no files or folders on the file manager. I’ve tried this by installing pCloud in two ways on Manjaro KDE.

pCloud Drive looks completely empty. I’ve tried this with two file managers, i.e. Dolphin and PcManFM-Qt. Same thing with ‘Open Drive’ from the ‘Account’ menu on pCloud Drive. However, when I select pCloud online from the ‘Account’ menu on pCloud Drive, it shows data and works as expected. Everything else on pCloud from system tray does seem to work - except, when I try the Sync option of the context menu of the pCloud Drive on Manjaro KDE, there is nothing to sync.

I have pCloud (aur/pcloud-drive 1.9.9-1) installed on EndeavourOS LXQT and pCloud Drive just works. On Manjaro KDE I’ve tried the earlier version (pcloud-drive 1.9.8-1, if I remember right) as well as the Appimage version. They do not work on Manjaro KDE.

Before I had Manjaro LXQT installed. Then, pCloud Drive worked as expected with the Appimage.

The sync worked between EndeavourOS and Manjaro LXQT. I’d like to sync my notes with pCloud between EndeavourOS and Manjaro KDE.

Could you please help to make pCloud Drive work on Manjaro KDE?

  1. pcloud is a paid subscription - and no user that I know of uses pcloud.
  2. third party applications are unsupported.

So to answer your question

Sorry - no can do.

My advise is to use a supported distribution or use as your issue seems to be unique to Plasma - you could use another version of Manjaro.

You can find fresh builds on

Thank you very much for your reply, linux-aarhus. I was impressed.

pCloud’s Support advised me to delete the database of the app:

1 - Delete /home/@USERNAME/.pcloud
2 - Delete /home/@USERNAME/.config/autostart/pcloud

Unfortunately, it didn’t work with the AUR and Appimage versions of pcloud on Manjaro KDE.

The issue is probably unique to Plasma. I’ll try another desktop environments of Manjaro, e.g. LXQT - and then another distro, if needed.