Password of the user only works for initial log in and then it changes

I am complete noob with no IT related experience.Thanks in advance.

  1. I set same password for user and admin in the installation
    2)it worked fine 1st reboot after installation. I was able to install updates, able to change settings in pamac.
    3)now i can log in with my password but after that it seems to change
  2. in settings it shows like 5 digit one and my actual one is 11 digits
  3. initially i thought may be i set a different password for root
    6)so i used advanced settings for manjaro settings and changing the root password and the user pass word according to this youtube link https:// / zeQNtVT2Otw
  4. still it’s same . I can log in to my DE but I can’t update /install apps, i can’t change key settings. , Cant log out and log in again.But i can manually shut down by long pressing power button and turning back agin and log in

Passwords do not change on the fly … your keyboard layout might change, depending how you set it up, hence the characters typed are not always the same, resulting in typing the “wrong password”.

Aah how can set it right now. I don’t have any clue what to do

You cannot always deduct from the number of dots shown the length of the password.

Some systems displays a random number of dots and if they allow revealing it is not your password but random text which is shown. This is a security feature not a bug.

Rest assured that passwords does not change once set. Your memory may change - but not the password.

To solve your immediate issue - boot a live Manjaro ISO and ensure your are using the correct keyboard layout. Then open a terminal and run

sudo manjaro-chroot

When the command completes you are inside your installed Manjaro. Then change passwords - do not be alarmed - you will not see the characters entered or the number of charaters - this is not a flaw or a bug - it is a security feature.

passwd root

And then your user - replace USERNAME with the actual username


Hi @naveen000can,

Please see [root tip] Troubleshooting locale errors regarding the keyboard layout.

But i did changed the password in advansed setting manjaro by going to the section for changing the kernal version and clicking in “E” and by executing a bash command there i was successfully changed password but still it’s same . You can check the video link i gave. Just remove the spaces in the url address

Hi @naveen000can,

Please see [HowTo] post screenshots and links and edit your post accordingly.

Also, if you change the keyboard and ensure it’s right, it’ll be much easier for everyone involved.

Also, the global keyboard layout an be different from the per-user keyboard layout. That might be the cause of the password working initially, then stopping after login and the user’s custom layout getting applied.


Definitely that’s that I’m trying and i will post it soon as possible. Thank you so much for your reply

1 Like

Sorry i wanted to ask. I didn’t use alot of different charecters in the password and only one I used is “#” in it all others are numbers and plain English letters and the keyboard layout i used is standard american keyboard layout

Please post the output of::

locale -a


localectl list-locales


sudo localectl list-locales

And finally,

sudo locale -a

You are right it’s a key board layout issue, like i said i yried to use # sign but because it selected the british layout it takes that as the pounds sign

1 Like

i understood that my initial login keyboard layout is in uk layout. so I was able to change password and for now i can work around it but still its real pain can anyone tell me how to change uk standard english layout to the US one

System Settings → Keyboard (sometimes labeled Input)

Thats system locale right;? I changed that to en_us.utf-8
But I’m asking only for initial log in screen. May be it have something to do with vc key map set to uk and or x11 layout set to gb

You can check the files - if you set two locales you can switch between them - but I don’t know it this is supported by gdm

  • X11 → /etc/X11/xorg.conf.d/00-keyboard.conf - example
    $ cat /etc/X11/xorg.conf.d/00-keyboard.conf
    Section "InputClass"
      Identifier "system-keyboard"
      MatchIsKeyboard "on"
      Option "XkbLayout" "dk"
  • console → /etc/vconsole.conf - example
    $ cat /etc/vconsole.conf

You can use localectl to set the keyboard - both console and X

$ localectl --help
localectl [OPTIONS...] COMMAND ...

Query or change system locale and keyboard settings.

  status                   Show current locale settings
  set-locale LOCALE...     Set system locale
  list-locales             Show known locales
  set-keymap MAP [MAP]     Set console and X11 keyboard mappings
  list-keymaps             Show known virtual console keyboard mappings
  set-x11-keymap LAYOUT [MODEL [VARIANT [OPTIONS]]]
                           Set X11 and console keyboard mappings
  list-x11-keymap-models   Show known X11 keyboard mapping models
  list-x11-keymap-layouts  Show known X11 keyboard mapping layouts
  list-x11-keymap-variants [LAYOUT]
                           Show known X11 keyboard mapping variants
  list-x11-keymap-options  Show known X11 keyboard mapping options

  -h --help                Show this help
     --version             Show package version
     --no-pager            Do not pipe output into a pager
     --no-ask-password     Do not prompt for password
  -H --host=[USER@]HOST    Operate on remote host
  -M --machine=CONTAINER   Operate on local container
     --no-convert          Don't convert keyboard mappings

See the localectl(1) man page for details.

Thank you so much. I was able change x11 and vc layouts eaily

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.