Panel not remembering settings after reboot & screen edges not working

  Kernel: 5.15.38-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.24.5 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 1 v: Rev 1.xx
    serial: <filter> UEFI: American Megatrends v: 1501 date: 07/13/2021
  Info: quad core model: Intel Core i7-7700 bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 800 min/max: 800/4200 cores: 1: 800 2: 800 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 510.68.02
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: nvidia
    gpu: nvidia resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02

This is the system. Last stable update no problems.
First Plasma problem-- after entering edit mode to set up the panel layout, exit and reboot. Panel does not remember settings from edit. System is set to start to empty session.

Second Plasma problem- I am using the full screen app launcher. In System Settings/Workspace Behavior/Screen edges I set the 3 left screen edges to application launcher…No matter which of the “Show Alternatives” I have selected when left clicking on the Application Launcher icon in the panel, moving the pointer to the left hand side of the screen does not activate anything. It does show a thin blue line when I touch the left hand side fo the screen but no app launcher.

I have deleted the panel and re created it several times and configured it but aside from the different widgets I put there, the order is not remembered. No matter whether it is set to left, center or right justify, same results.
I have also disabled and re-eneabled the screen edges settings. My right screen edge is set to show the different desktops and this works properly. Note that this is a dual monitor desktop with the left monitor set as the primary monitor.The monitors are set tiled to increase desktop area.

Edit-- Also note that on the screen edges problem, if I set the left screen edges to “Desktop Grid” that works without problem. Only the application launcher selection seems to be not working.
Any suggestions would be appreciated. Many thanks.

try creating a new user, and test with it if you have the same issues

1 Like

Thanks for the interest and reply. Will try that.

Created new user. Panel operates as its supposed to. Screen edges settings result in launching the applications launcher I have selected without problems. How to fix the original desktop ??
What would be the best solution here? To create another user and re configure it , then deleting the desktop/user I am having problems with or are there user files that can be deleted and reconfigure the original user account?
Many thanks for this suggestion brahma, first time I have approached this type of problem in this manner…

try these commands:
rm -rf ~/.cache/*
rm ~/.config/Trolltech.conf
kbuildsycoca5 --noincremental
reboot and check if it helped

1 Like

No help same problem but thanks…

so resseting plasma settings could help:

  1. Log out of KDE.
  2. Switch to TTY with CTRL + ALT + F2 - if f2 doesnt work, try f1-f6 instead
  3. Login in TTY with your ‘bad’ account
  4. Stop the Display Manager service:
sudo systemctl stop display-manager.service
  1. Run this command to reset the settings:

find $HOME/.config/ -maxdepth 1 -name 'plasma*' -exec rm {} \;

clear cache:
rm -rf ~/.cache/*

  1. reboot:
    systemctl reboot

hopefully this will help, otherwise create the new user, copy browser …etc settings from the old one into the new one…


Thanks very much for this. Cured the panel problems, now the panel remembers settings from boot to boot. However I still am not able to launch the application launcher via touching the screen edge that I have configured to launch the launcher. No matter where I configure the app launcher to be launched “from” it will not launch. However anything else I configure to launch from System Settings/Windows Behavior/ Screen edges…launches without problem–just not the activity launcher. I am at somewhat of a loss on this because it worked before… one might ask before what but it worked after the last stable update and it works on the test account I set up ----So I am at somewhat of a loss.
At this point other than configuring a new account i am not syure what solution there might be. This is a reinstall --reinstalled fresh Manjaro Stable to an M2 drive and moved /home over a week ago- then went through the last Stable update without problem-- of a production system that was some 4 years old so there is a lot to do in configging a new account.

Many thanks again for your kind help.

Brahma & forum

I went back and looked at some notes that I was made today. I think what initiated the problems was I changed themes from Breath Dark to Breeze Dark. When I did this I checked the " Use Desktop Layout from theme" selection at the bottom of the Global Theme page. That was when the problem started. Since my last post here I have created several different user accounts and tried different things. What I have discovered is that-on my system at least- once a user is created its possible to enable screen activation of the App Launcher or any other screen edge setting. In my case–If I change theme and also check “Use Desktop layout” at the bottom of the Global page then it has been no longer possible for me to get the App Launcher to work with a screen edge. I have created a number of different user accounts to investigate this. All of the other screen edge settings work…but no app launcher once you change global themes and use the desktop layout from that theme by checking the box at the bottom of the page. Changing themes without the box checked did not affect functionality of any of the screen edge settings including the app launcher.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.