Pamac upgrade: removing pulseaudio breaks dependency 'pulseaudio=16.1-7' required by pulseaudio-equalizer

Hello, on 5.15.143-1-MANJARO with KDE I did “pamac upgrade -a”

Error: Failed to prepare transaction:
could not satisfy dependencies:
- removing pulseaudio breaks dependency 'pulseaudio=16.1-7' required by pulseaudio-equalizer

Edit build files : [e] 
Apply transaction ? [e/y/N] y

Transaction cancelled.

Why this happened? System should be up to date.
What is easiest way to deal/fix with such issue?

Show us more.
Otherwise the answer is remove pulseaudio-equalizer.

I wonder why an update would want to remove pulseaudio.

Well, we need more terminal output to understand what is going on …

Here is requested full output of the pamac upgrade command.

then it says same error, only required package is “pulseaudio-jack”…

In case its pamacs fault, lets try with pacman.

sudo pacman -Syu

(and I want to see the output, or at least the end)

Response does not show pulseaudio was removed to trigger removal of pulseaudio-equalizer

why are you using both options -a and --aur for AUR updates?

I would suggest add ungoogled-chromium and libreoffice-fresh to pacman.conf Ignore list if you want to avoid updating packages

and try updating without AUR and pipe to /dev/null/

pamac update --no-aur

I have tried “pamac upgrade --no-aur” and it no longer has an issue. But with --aur, it has the issue from the title of this thread. Output.

This command is OK, maybe because it is not using AUR. Output.

Then you need to manage your unsupported packages.

There are a TON of AUR things in that update.

Refreshing AUR...   
Warning: ungoogled-chromium: ignoring package upgrade (86.0.4240.198-1 => 120.0.6099.129-1)                                                                                                  
Cloning hw-probe build files...
Generating hw-probe information...
Checking hw-probe dependencies...
Checking nx-x11 dependencies...
Cloning flashpoint-bin build files...
Generating flashpoint-bin information...
Checking flashpoint-bin dependencies...
Cloning python2 build files...
Generating python2 information...
Checking python2 dependencies...
Cloning orage build files...

------ etc etc etc-------

fatal: unable to access '': Could not resolve host:

------ etc etc etc-------

AUR is not supported, but if you want to use it you should be on unstable branch and be prepared things can break.

As for the pulseaudio error, I would install manjaro-pipewire and forget about pulseaudio as it is legacy.
If it complains about pulseaudio things being dependent, remove those and then retry to install pipewire.

flashpoint-bin requires pipewire-pulse – dependency was added 2023-11-21
and pipewire-pulse conflicts with pulseaudio

I suspect pipewire-pulse has already been installed without using metapackage manjaro-pipewire to ensure optional dependencies like pulseaudio-equalizer were also removed

This is very broad for understanding what to do. (manage, unsupported) But thank you.

After doing “sudo pacman -S manjaro-pipewire” and confirming removal of numerous pulseaudio packages, audio continued playing and “pamac upgrade/upgrade” and “pacman -Syyu” worked without issues. After rebooting, sound is playing and pamac update/upgrade works.
Btw. there are still installed pavucontrol, pipewire-alsa/pulse, pulseaudio-ctl, xfce4-pulseaudio-plugin (when i have searched for “pulseaudio”).

So the issue seems to be solved for me by installing manjaro-pipewire as suggested by bedna. Thank you.

Glad it worked out.

When finding a solution, please mark the answer that gave you the sollution with the solution button :white_check_mark:
That way others who might have a similar problem can find the solution immediately and the thread will close after a few days.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.