Pamac update "Operation not supported"

Hi guys!

I am new to the forums so sorry for any wrong category I think this should be correct.
So following when I run pamac update following happens:

pamac update
Synchronizing package databases…
ftp ://mirrorDOTeasynameDOTat/manjaro/stable/core/x86_64/core.db: Operation not supported
ftp ://mirrorDOTeasynameDOTat/manjaro/stable/extra/x86_64/extra.db: Operation not supported
ftp ://mirrorDOTeasynameDOTat/manjaro/stable/community/x86_64/community.db: Operation not supported
ftp ://mirrorDOTeasynameDOTat/manjaro/stable/multilib/x86_64/multilib.db: Operation not supported
Nothing to do.
Transaction successfully finished.

Basically the operation is not permitted (hopes are I did not screw up any packages regarding ftp).
I checked with dolphin on the ftp it looks fine.
I checked via https the Index of the mirror it looks fine.

Last time I had this I recreated my mirrrors which now looks like this (mirrorlist):

Manjaro Linux custom mirrorlist
Generated on 2021-12-25 11:55

Please use ‘pacman-mirrors -id’ To reset custom mirrorlist
Please use ‘pacman-mirrors -c all’ To reset custom mirrorlist
To remove custom config run ‘pacman-mirrors -c all’

Country : Austria
Server = ftp mirrorDOTeasynameDOTat/manjaro/stable/$repo/$arch
Country : Germany
Server = https mirrorDOT23mDOTcom/manjaro/stable/$repo/$arch
Country : Germany
Server = ftp ftpDOTtu-chemnitzDOTde/pub/linux/manjaro/stable/$repo/$arch
(and a few more)

I noticed https has no issues for me. But if I comment out until the next ftp:
pamac update
Synchronizing package databases…
ftp //ftp.tu-chemnitzDOTde/pub/linux/manjaro/stable/core/x86_64/core.db: Operation not supported
Transaction successfully finished.

Links are not allowed here… how odd
How do I fix this?

Besides the solution please consider this: Pamac update "Operation not supported" - #13 by Legion495

Why the ftp mirrors? https is faster.

From the message it seems the easyname mirror has taken down ftp support.

In any case - issues with a specific mirror is a jobl for the mirror maintainer not Manjaro.

1 Like

Because it was default and I did not touch it until I had the issue.
The question still is what the issue is.

Changing to https is just a bandaid.

Hi @Legion495, and welcome!

Run the following to check your mirrors and reset them to default :point_down:

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pacman -Syyu

If that still l doesn’t work, assuming you’ve got shiny-mirrors try using that to configure your mirrors.


I disagree. Its faster and it’s encrypted, where ftp isn’t.


That is new to me.

The mirrorlist is autogenerated and pacman-mirrors will prioritize https over http over ftp - so your system having ftp is a deliberate choice you have made.

0.264 Austria :
Literally the connection the command shows me. It is still at work.

One way or another - it is a deliberate choice.

Check the content of /var/lib/pacman-mirrors. If you have a file custom-mirrors.json then you have at some point customized your mirror pool.

pacman-mirrors would never choose an ftp mirror when https or http is available.

I have a status.json in that folder.
I have found the entry for Austria there too

    "country": "Austria",
    "last_sync": "00:11",
    "protocols": [
    "url": ""

In that case we have a bug - I will take a look at it

Okay so I ran it. Of couse I can use the other mirrors so at least the update issue is fixed (even if I would prefer the local mirror).

Country : Australia
Server = https ://$repo/$arch
Country : Belgium
Server = http ://$repo/$arch
Country : Bulgaria
Server = http ://$repo/$arch
Country : Belarus
Server = http ://$repo/$arch
Country : Austria
Server = ftp ://$repo/$arch

Works until I go to ftp again. Why I consider this a bandaid is not because i think http(s) is worse but if I have other applications using ftp that it might fail. That I by chance have a underlying issue with ftp at hand here.
And I noticed from the command earlier that my terminal cannot handle ftps it seems.

::ERROR unknown url type: ftps

That is not your terminal but a shortcoming of the python library used.

1 Like

See here, I believe it’s something close to if not exactly this:

1 Like

Cool. So I was wondering because my laptop and my desktop ran into the same issue.
I honestly thought the mirror broke.
Makes sense if there was a change and me running ftp as repo mirror on top of that.

I will mark the above command as solution as it fetches most likely a mirror with http/https.
If that is okay with everyone. (After all the bug has been indentified that it should go http first)

But also want to add here that anyone having the issues might as well exchange ftp to http/https in the mirrorlist to circumvent having to use a different mirror in the first place. (in /etc/pacman.d/mirrorlist)

Thank you everyone for the super fast support. Unreal how fast you guys are.

I found the reason.

As it appears I have forgotten to reverse the protocol list sort when testing mirrors.

This puts the ftp on top - which most certainly was not intended.


I apologize - your ftp issue appeared to be my fault.

pacman-mirrors 4.23.2-1 has been pushed to the repos and will begin propagation to the mirrors shortly.


Aaaand it appears it is, already, causing issues… :wink:

Just some fun!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.