Pamac update fails with huge amount of errors plasma-desktop-primex

Hi hope this is the correct place for this.

Been chugging along on Manjaro Kde for some time now. NO major changes nothing out of the ordinary installed.

I get an update message (401) updates. I start the update…

Hangs every time with a ton of error messages with this at the end, this is only a few. I can post the entire thing if needed.

  • plasma-workspace: /usr/lib/qt/plugins/ already exists in filesystem (owned by plasma-desktop-primex)
  • plasma-workspace: /usr/lib/qt/plugins/kcms/ already exists in filesystem (owned by plasma-desktop-prim
  • plasma-workspace: /usr/lib/qt/plugins/kcms/ already exists in filesystem (owned by plasma-desktop-pri
  • plasma-workspace: /usr/lib/qt/plugins/kcms/ already exists in filesystem (owned by plasma-desktop-
  • plasma-workspace: /usr/share/doc/HTML/ca/kcontrol/autostart/index.cache.bz2 already exists in filesystem (owned by pla
  • plasma-workspace: /usr/share/doc/HTML/ca/kcontrol/autostart/index.docbook already exists in filesystem (owned by plasm
  • plasma-workspace: /usr/share/doc/HTML/ca/kcontrol/formats/index.cache.bz2 already exists in filesystem (owned by plasm

More info needed just ask, never sure what to include.

Also lost any and all mouse and/or trackpad setting suddenly, separate issue I know but Dang is this frustrating constantly touching that thing with no way to turn it off that I can see (was there).

plasma-desktop-primex package is obsolete, install plasma-desktop which will replace it


Good lord this is frustrating, I also lost all mouse/trackpad settings. Sooo frustrating trying to type and making contact with the pad. Tried to solve that and it’s tied into the same error messages.

All this from an update?

Trying to install that package now, thanks I will let you know. Servers seem to be REALLY slow

Holy Smokes.
That worked!
I have been reading for hours and nowhere did I see something that made it that clear and concise.
This did tie in somehow with the track-pad bs as well, all the controls came back and that dastardly thing is turned off again. I know some people probably love it but I basically always have access to a trackball.

Just out of curiosity, if you want to address it. Why did this update cause all this? Like I said I have not intentionally changed/installed anything that would relate to this that I know of, just official update stuff. If it’s too much to get into that’s ok, no problem.


You can’t imagine how this just turned my day around…

I think this package was made to resolve issue with fingerprint sensor on laptops. Don’t know how it landed on people’s computer. Maybe it was shipped with some ISO back then. Can’t find the history behind this package.

1 Like

first entry found is this (and not go from iso ???)


Ahhhh. Yeah that might be it.

:: Replace knetattach with extra/plasma-desktop? [Y/n] y
:: Replace knetattach with extra/plasma-desktop-primex? [Y/n] y

Probably back then (just extrapolating) knetattach got merged into plasma-desktop, and then it asked to replace it twice, with both packages providing the replacement, and ended up with plasma-desktop-primex. That could make sense.


I will pretend I have a clue what you folks are talking about but it is interesting just the same. Sure made a mess of things for more than a few hours.

Thanks for the replies and especially thanks for the help!!

Had the same problem. Just used sudo pamac install plasma-desktop and pamac made the all things including removing plasma-desktop-prime and updating.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.