Pamac triggers search after the 3rd letter is typed

When you open Pamac for the first time, then start to type, after the 3rd letter is typed the typing process is blocked and the search is started automatically even if the user already typed more than 3 letters, after 1 to two 2 seconds the drop-down list is shown with possible results, and the rest of the letters are then added to typed text. simplescreenrecorder-2023-03-17_10.45.45 on Vimeo

1 Like

So from the video it did exactly as it’s designed to do. That said in my opinion with all the past headaches because of too much poling of the AUR by pamac pamac should be designed to only search once you’ve entered your text and hit enter.

1 Like

But it starts searching directly after the 3rd letter without letting the user finish typing the whole wanted text, what is normal is to let the user finishes typing the whole text and when it detects that no keys are pressed (for e.g in laps of 500ms) then it should start searching.

2 Likes

AFAIK pamac downloads, saves uses a locally cached copy, so does not poll the AUR with that many keystrokes.

So that list that appears after typing 3 letters is not loaded from AUR ? So why does it take so long to appear ?

To start narrowing the results down and continue to narrow it down as you type further…

Say you’re looking for a package msi-keyboard-light.

If you search pamac for “m” there are many more results, “ms” is better, and “msi” is almost all you need.

So the problem comes from the way search in the local AUR cache is implemented, I think it’s either related to the data structure of AUR local cache (not optimized for fast search), or due to the use of one thread both for consuming user pressed keys and processing the local search, because that 1 to 2 seconds is totally obvious and truthfully is annoying.

This has been a subject of discussion many times AFAIK. And this is the best compromise between everyone.

Personally I use the command line, but even before I started using only that, it wasn’t bad. Especially when you consider that you’re not coughing up hundreds of bucks for it. Or in my case, it would’ve been thousands. It still is, for my wife.

It’s just :disappointed:, being the only app from Manjaro team and it’s not up to users expectations.

Thing is, you can’t please everyone.

And maybe it’s just me, I don’t know, but I don’t think one can expect more from something that you get for free. But maybe that’s just me.

3 Likes

Well, actually it triggers to load the database into the RAM Cache after typing the 3rd character. Before it would send a web request, now it is a local database. I guess the file is just very big and needs 1sec to load (at least on my system).

Anyway… when loaded, it is smooth.

Btw… I cannot view the video because it needs Evaluation. :man_shrugging:

I have to agree that I would prefer the search to start after the first word or pause, instead of stopping what I write at the third character.

2 Likes

Why not load it when the app is starting (only if AUR is enabled) ?

2 Likes

I am experiencing this as well and yes, it’s kind of annoying that pamac gets non-responsive for about 2 seconds after you typed 3 letters into the search box.

Wouldn’t it be better to load that database into RAM on pamac startup? 2 secs of additional startup time shouldn’t be an issue. Or am I missing something here?

1 Like

That is legit. Maybe file an issue here: Issues · Applications / pamac · GitLab

2 Likes

Done Load AUR local database cache (if AUR is enabled) when Pamac starts (#1326) · Issues · Applications / pamac · GitLab

2 Likes

Was just there. Isn’t logged in, so can’t comment. I think just put a link to this post as relevant in the description. It can only help.

pamac should be designed to only search once you’ve entered your text and hit enter.

Tha…
…t was how the search used to behave before the autocomplete was added

Tur…
…ning off AUR reduces the glitch to a micro-pause (but no AUR packages)

If …
…there is not viable solution soon, maybe Manjaro Team could consider adding an option in Preferences to turn autocomplete off?

Pamac-manager is one of the most important features of Manjaro and is mostly excellent
I don’t like the new multi-column fluid style, so I use it with a narrow window
I don’t need software mode, so I keep it turned off
plugins for snap/flatpak are not installed
But the ‘mostly excellent’ emphasises the one remaining glitch

I’ve gone to pikaur over paru or yat and using pacseek over pamac.

Seems like a viable option, but as the feature was added because it was thought useful, I guess working to add a feature to disable that wanted (by devs) feature is probably not gonna happen. I guess fixing the search hang is more viable for everyone.