Pamac not found Error 404

$ pamac --version
Pamac  10.2.0-1

$ pacman -Qi libpamac | grep Version
Version         : 11.1.0-1

current version which was able to download and update after switching to a different download mirror, and I did reboot yes.

:question: :pray: :bowing_man:


Uh… this Kernel has been outdated for quite some time now… you should either use 5.10 LTS or 5.14

1 Like

Linux 5.12 has been released on Sun, 25 Apr 2021. wouldn’t exactly call it out of date, when it hasn’t been marked as such yet when its only 2 versions behind. I rarely update the kernel anyway, because I usually hang back by at least 2 versions because I need a stable working environment without things breaking.

This kernel has been EOL since July 20th, which is why Manjaro no longer offers it. If you need a stable environment, why not run an LTS kernel such as 5.10?

1 Like

I think is it very nice that you try to think yourself in your way to serve your purposes! :+1:
But sometimes there are situations with no other valid answers on a 2+2 equation, except the only one. Mankind did not find yet. May be you can find other, OK, why not to try.

You can re-check the or your trusted sources: the 5.12 is even removed from the list of actual kernels there. It is a history for 1.5-2 months at least.

Your segfault issue could be caused by unsupported and non-fixed-in-somewhat kernel version.
Of course it is up to you whom to listen, where to find info, what to try. Freedom to think, to try, to use whatever. And the topic issue could be caused the 5.12 kernel, but could be not, we do not know exactly, community members usually guessing only, may be you are right that it is not caused by 5.12.

BTW, you also can install other kernel version, try it, see that it having the issue or not and than decide to switch back to your favorite 5.12 or to stay at currently tried.

May be other users will suggest other ideas why the issue can occur and what to try else.
Currenly you have the newest versions of the pamac and libpamac, so it is actual, which other use, me too. I do not have the issue.

As you see currently active solutions are: 5.4 LTS, 5.10 LTS, next upper/newer is only 5.14 called stable now and currently beta (publicly testing) version of 5.15. That info I got from the link at the beginning of that my post.

I think you may have a partially updated system. Execute a system update

sudo pacman -Syyu
1 Like

So please read this:

Especially the Linux has multiple kernels section, then try an LTS kernel and hopefully the problem will go away “automagically”. :grin:


Changing kernels didn’t make the problem go away, pamac still segfaults when trying to refresh its database when it hits 95%.

Have you tried the first solution here yet?

I.E. You might have issues to install this update by missing Maintainers keys because that deleted the pamac DB and recreates it.


OK nothing from that post is helping me, it’s got nothing to do with missing maintainer keys. The application is flat broken with no explanation other than segfault. The cause of the segfault is unknown.

What’s the output to

lsb_release --all


So after

Alkaris still did not that?
I though that we went further, and the getting all of updates is already in the past.

What if your storage has a bad block?

Try to re-install all packages, including pamac (cause pamac has several dependencies of packages) with re-configuring the pamac (case of config files is bad and pamac uses a wrongly read value at some point (that 95%) and than segfauls while trying to use that faulty value):

  1. Close pamac system tray icon.
  2. Remove pamac app settings: rm -rf ~/.config/pamac
  3. Purge cache of downloaded packages: sudo pacman -Scc (Y everywhere)
  4. Re-install all packages with pacman: pacman/Tips and tricks - ArchWiki
$ su

enter root’s password (not your user’s one; that password you already entered at least at the OS installation stage) and than

# pacman -Qqn | pacman -S -

and after

# exit

Reboot the PC and re-check the db update via terminal

$ pamac update --force-refresh

if still segfaults, re-initialize other pamac dependencies like re-installation DBs and keys: Update archive corrupted - #10 by linux-aarhus

If you want you can report your case in order to get developers support, if you believe that it is the app problem and not your environment case: Issues · Applications / pamac · GitLab
But all participants/poster of that thread don’t have that issue, otherwise they would tell about that problem too. I think most probably it is your environment issue (other software around pamac or hardware).

There’s no mention of a bad or corrupted DB at all, also I don’t know what version of pamac you’re using, but Pamac does not have the flag option --force-refresh, the list of available option flags are as follows;

$ pamac --force-refresh
Available actions:
  pamac --version     
  pamac --help, -h     [action]
  pamac search         [options] <package(s)>
  pamac list           [options] <package(s)>
  pamac info           [options] <package(s)>
  pamac install        [options] <package(s)>
  pamac reinstall      [options] <package(s)>
  pamac remove         [options] [package(s)]
  pamac checkupdates   [options]
  pamac update,upgrade [options]
  pamac clone          [options] <package(s)>
  pamac build          [options] [package(s)]
  pamac clean          [options]

Ok now you’re just running off into the deep end and assuming things now.

this is what I get;

LSB Version:	n/a
Distributor ID:	ManjaroLinux
Description:	Manjaro Linux
Release:	21.1.4
Codename:	Pahvo
pamac update -h

:wink: we can also use: man pamac

Because you think anyone here knows what is causing your issue?
Try things. It doesn’t hurt.

If to look into the [Stable Update] 2021-09-24 - Kernels, LibreOffice, Browsers, Pipewire, RHVoice, KDE Frameworks, Mesa - #3 by philm
then we can see that possible correlation with suggestion to re-install all packages:

I suggested to re-install all packages at once (and pamac’s config also: how many time you will re-configure the pamac settings? 30 or 40 seconds?) cause you may have another packages and software libraries damaged on storage, so that possible solution covers more cases at once, but download and installation of all that stuff (about 1.5 GB) will take some time.

Or may be you already tried to re-install pamac with all of if dependencies.

Also, do you know how pamac or an app works on try to read a file with a bad block? What if pamac segfaults while read that corrupted DB? Or may be you know for sure that it can’t be?

I think you waste more time to resist to the idea of a possible solution (only possible, not exactly 100% warranty of fix) than to get it tried already. It is your choice to be a new posts writer or to came a bit closer or even solve the issue.

Even more: may be pamac segfaults on try to show you a note that a DB is corrupted. But somehow you judges by yourself that there is no correlation.

Pamac Segmentation Fault: Pamac Segmentation Fault - #6 by The_Quantum_Alpha


accepted as solution.
@Alkaris forgot to read manual of pamac(--force-refresh), forgot to search the forum? What comfort you get using somewhat without tries to learn it more? Less knowledge brings less abilities, less choice options, so less comfort.

False, and you just assumed, yet again.

Yet you assume again, and throw out more useless information. Enough already.

This topics dead, no point telling me more useless information thats not going to help me here.


Closed as per OP’s request. As no solution was posted, solution was removed.