Pamac not found Error 404

I was having some issues using pamac for checking for updates and downloading new package upgrades, when I go to Updates tab the progress reaches 95% and then segfaults. So I tried to reinstall pamac and its dependencies, but when I go to install them with Pacman I get the following errors;

pamac-cli-10.1.3-3-x86_64.pkg.tar.zst failed to download
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
error: failed retrieving file 'pamac-cli-10.1.3-3-x86_64.pkg.tar.zst' from : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

Did pamac somehow get deleted from the mirrors? I checked the server status with `pacman-mirrors and they return OK for these mirrors.

Pacman-mirrors version 4.21.5
Local mirror status for stable branch
Mirror #1   OK  00:12   Germany
Mirror #2   OK  00:51   United_Kingdom
Mirror #3   OK  00:12   Germany
Mirror #4   OK  00:10   Japan 
Mirror #5   --  02:43   South_Korea
Mirror #6   OK  00:14   Ukraine
Mirror #7   OK  00:42   Hungary
Mirror #8   OK  00:41   United_States

I tried refreshing pacman package database and it gets them just fine, but it’s still unable to retrieve the package for pamac-cli.

Tried seeing if this error happens when trying to install packages for other stuff and the same result also, it’s also throwing Error 404 when trying to get from the server…

you use and is not good (not sync), select another mirror
we can run pacman-mirrors with --interactive option for remove this mirror

It looks like you are on stable branch (according to your profile desc).

The Index of /manjaro/stable/extra/x86_64/ server has the pamac-cli-10.2.0-1-x86_64.pkg.tar.zst

So your local database is outdated.

Try to refresh it:

sudo pacman-mirrors -B stable -c Germany -P https -a

and than

sudo pacman -Syyu

Doing so will probably lead in issue with the mirror as this one is having issues since one or two weeks at least, and is always the most responsive mirror in Germany every time I test it, so most likely the user will use this broken mirror then.
I recommend to chose another country for the time being until this mirror is fixed (didn’t find any way to contact owner so far), or is removed from Manjaro mirrors list at some point if it never gets fixed. Alternatively, adding this domain to the /etc/hosts file to redirect it to localhost is a workaround to continue to sync to Germany mirrors.

1 Like

I don’t particularly feel like messing with the hosts file, I can just remove it from the mirror list and select another.

Well you need to refresh the database for pamac also:

pamac update --force-refresh
1 Like

I’ve sorted this already now, changed servers and stuff.

But now I’m with a broken pamac that now segfaults when refreshing the database for updates, it gets to 95% and then segfaults, so I can’t even update software with pamac, instead I have to use pacman.

Thread 46 "get_updates" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff19d8640 (LWP 1099111)]
0x00007ffff734c9d0 in g_str_hash () from /usr/lib/

What system specs are you running:

  1. kernel version,
  2. did you reboot PC after updates,
  3. which pamac and libpamac (pacman -Qi libpamac | grep Version) versions do you have


$ pamac --version
Pamac  10.2.0-1

$ pacman -Qi libpamac | grep Version
Version         : 11.1.0-1

current version which was able to download and update after switching to a different download mirror, and I did reboot yes.

:question: :pray: :bowing_man:


Uh… this Kernel has been outdated for quite some time now… you should either use 5.10 LTS or 5.14

1 Like

Linux 5.12 has been released on Sun, 25 Apr 2021. wouldn’t exactly call it out of date, when it hasn’t been marked as such yet when its only 2 versions behind. I rarely update the kernel anyway, because I usually hang back by at least 2 versions because I need a stable working environment without things breaking.

This kernel has been EOL since July 20th, which is why Manjaro no longer offers it. If you need a stable environment, why not run an LTS kernel such as 5.10?

1 Like

I think is it very nice that you try to think yourself in your way to serve your purposes! :+1:
But sometimes there are situations with no other valid answers on a 2+2 equation, except the only one. Mankind did not find yet. May be you can find other, OK, why not to try.

You can re-check the or your trusted sources: the 5.12 is even removed from the list of actual kernels there. It is a history for 1.5-2 months at least.

Your segfault issue could be caused by unsupported and non-fixed-in-somewhat kernel version.
Of course it is up to you whom to listen, where to find info, what to try. Freedom to think, to try, to use whatever. And the topic issue could be caused the 5.12 kernel, but could be not, we do not know exactly, community members usually guessing only, may be you are right that it is not caused by 5.12.

BTW, you also can install other kernel version, try it, see that it having the issue or not and than decide to switch back to your favorite 5.12 or to stay at currently tried.

May be other users will suggest other ideas why the issue can occur and what to try else.
Currenly you have the newest versions of the pamac and libpamac, so it is actual, which other use, me too. I do not have the issue.

As you see currently active solutions are: 5.4 LTS, 5.10 LTS, next upper/newer is only 5.14 called stable now and currently beta (publicly testing) version of 5.15. That info I got from the link at the beginning of that my post.

I think you may have a partially updated system. Execute a system update

sudo pacman -Syyu
1 Like

So please read this:

Especially the Linux has multiple kernels section, then try an LTS kernel and hopefully the problem will go away “automagically”. :grin:


Changing kernels didn’t make the problem go away, pamac still segfaults when trying to refresh its database when it hits 95%.

Have you tried the first solution here yet?

I.E. You might have issues to install this update by missing Maintainers keys because that deleted the pamac DB and recreates it.


OK nothing from that post is helping me, it’s got nothing to do with missing maintainer keys. The application is flat broken with no explanation other than segfault. The cause of the segfault is unknown.