Pamac not following system themes (Plasma)

Since a month or maybe more, I noticed that pamac defaulted its look and is no longer following GTK theming on Plasma.
I checked other GTK apps on my system, and they all look all right. Reapplying GTK theme didn’t help. There were many Plasma updates or KDE framework updates since then, and it wasn’t fixed, so I started wondering if it is something in my system. On the other hand, Pamac changed a bit and is no longer asking for password on a stupid repo refresh, so maybe it was Pamac’s update that forced “root look” so to speak.

This is how it looks now:

So the questions are: Does anyone know anything about this? Is it only on my system (config error?)? Is it some known pamac or Plasma bug?


1 Like

Hi @michaldybczak,

While I don’t use Gnome, or Pamacs GUI I know, as would you have if you searched first, I pamac is being upgraded from using GTK 3 to GTK 4 and this is causing it. You can switch to the old one if you prefer:

pamac install pamac-gtk3

Note: This will replace pamac-gtk, so it will probably want to remove it as a conflict. So go ahead with that if asked.


That is interesting and most likely reason for this (small) issue. So Plasma isn’t capable of setting themes on GTK4 apps at the moment?


I don’t know but don’t think so at the moment…

1 Like

Hmm… on the KDE store, there is section GTK3/GTK themes…

My theme is also in this category:

1 Like

Yes, but neither KDE, nor Qt is Pamac. And it’s Pamac that needs to use it.


So it would seem you need to upgrade your GTK version, or something. Because this is mine in Plasma:

I don’t understand. If you set the theme in GTK section in Plasma, all GTK apps use it by default and Pamac was not an exception till recently. So what changed?
GTK4 exists since a while, so it would be strange from KDE devs not to implement it into their system, and from the themes’s site it looks they have. So the issue is probably not with the update from GTK3 to GTK4, but something else.

OK, let me check that out.

These are my settings:

I also have Breeze but WhiteSur GTK theme. I opened pamac with terminal and I see this spammed error:

(pamac-manager:9623): Gtk-CRITICAL **: 10:57:24.233: _gtk_css_corner_value_get_x: assertion 'corner->class == &GTK_CSS_VA
LUE_CORNER' failed

Something seems missing, is corrupted or incorrectly configured. Maybe I need some additional package or have some old, legacy package that is conflicting? Hmm…

That’s what I just came to say. I see I’ve got both GTK3 and GTK4 installed:

$ pamac search gtk3                                                                                                                                                                                                  
gtk3                                                                                                                                                                                                  [Installed] 1:3.24.38-1                       extra
GObject-based multi-platform GUI toolkit


$ pamac search gtk4
gtk4                                                                                                                                                                                                             [Installed] 1:4.10.4-1                extra
GObject-based multi-platform GUI toolkit

So perhaps install the one you don’t have?

pamac install gtk3


pamac install gtk4


I have both: gtk4 and gtk3.

Let me get clear on that. If I have gtk4, I don’t need gtk3?
Usually when frameworks, or how it is called, gets a new major version, we require the old version for all apps that still use it.

At the moment, when I want to remove gtk3 and see what it will take along, it shows an error that it breaks dependency, so it can’t be uninstalled. So for example, filezilla needs it and I bet, if I uninstall filezilla, the new app turn out to use it as well, and so on.
Besides, if app is gtk4, it shoud use gtk4 libs, so why gtk3 would conflict here? Unless gtk4 is so badly designed…

That’s the theory, yes. However, I have no idea how backward-compatible, if any it is. I think this is why I opted to keep both versions, even though I don’t use Gnome.

So, I think that’s the best option IMHO…

I think we will need gtk3 for years to come, just as it is with gtk2. Gimp updated to gtk3 (still in beta) from gtk2, and probably it won’t move to gtk3 for the next 10 or more years.

Anyway, having gtk3 installed is not the cause and we seem to have a similar setup, just different gtk theme. However, it doesn’t matter what gtk theme I chose, pamac doesn’t follow it. If this works for you, it looks like the issue is only on my side and probably is somewhere in the configs. The problem is that those configs are probably not pamac but gtk related. I have 8 or even 9 year old install, so it’s likely I have some old configs that could cause issues.

I’ll check my test user to see if the issue is there as well.

1 Like

In the test user, pamac also doesn’t follow any gtk themes. It looks the same as for my main user, with the exception that the buttons are on the right side on the test user, so it looks like this customization works correctly. Other than that, gtk themes have no influence on pamac. This would rule out the config issue, so it must be tied to some packages. So far I can’t figure it out. I have basic gtk3 and gtk4 packages, no additional ones and AUR packages I have shouldn’t influence gtk look at all.

If someone has any idea how to debug it further, I’m all ears.

2 versions of pamac are floating around (don’t aks why): a gtk3 and a gtk4 based one. Either install the “classic” gtk3, or live with the new one that does’t do theming well. For the latter i fixed it here, but on xfce, don’t know if it will work on kde

It works on KDE, see here:

Also, I have both installed, see here:

Is there a way to check which installed gtk apps are gtk4?

From what I remember using Plasma few weeks ago, EasyEffects use Adwaita theme as well. If Pamac was written only with GTK4 without Adwaita widgets (libadwaita), it would be possible to use user theme without a hack. Don’t remember correctly, but themes need to support GTK4, and something needs to be copy-pasted to ~/.config/gtk-4.0 (rewriting GTK4 theme | I don’t know it is still possible). If you use themes from pling there should be instruction how to install/hack GTK4 + libadwaita themes.

I honestly don’t know.

It’s the fault of that stupid LibAdwaita that locked any possibility to theme GTK4 apps like we did with GTK3, with GTK4 and LibAdwaita you will have only dark and light default Adwaita themes working.