Pamac-manager: "Your system is up to date" - though it's not

Dear fellow Manjarees,
since a couple of weeks I experience a strange bug: On my multiple different installations of Manjaro, new updates are not being recognized in the pamac-manager. Instead it states “Your system is up-to-date”. When using the console with pacman, or triggering the “Refresh Databases” within pamac, the updates will be installed, but the bug persists.
How can I solve this?
With regards

Hi, this thread might have a solution:

1 Like

Optionally recreate mirrorlist using pacman-mirrors

$ sudo pacman-mirrors --continent

Then run pacman to sync your system (if you opted to use pacman-mirrors use double Y)

$ sudo pacman -Syu

Thank you both!
I will give it a shot, once new stable updates are available and report back.

So, the newest stable update is there. I have tried two things a week ago. On one machine:

$  sudo pacman-mirrors -f5 && sudo pacman -Syyu

On the other affected one:

$ sudo pacman-mirrors --continent
$ sudo pacman -Syyu

I also deleted the ~/.config/pamac.

To no prevail. Still no updates via pamac. It says “Your system is up-to-date”.
I am running out of ideas. Of course, I can update via console, but for my family (which I have served manjaro as delicious treat), that would be too complicated.

The pamac problem exists since pamac version 10 and has been addressed many times. Apart from the advice to take pacman, nothing seems to be going on. Sad, this case of update development. You can make do by pressing update database every time in the pamac burger menu.

Thank you for the workaround! I forgot about the “update database” trick.
A very sad situation though…

I updated Pamac today and it works flawless.
Don’t have anything to do and it updates just like it has to.

Pamac aur btw.

5 aur/pamac-aur-git 10.0.4.r4.ga08d9ae-1 [installed] [20+] [0.07%] [28 Feb 2021

We pushed some new versions to all branches, which hopefully fixes this issue …