Pamac GUI disappeared after large update

I have GTK4 on my Manjaro XFCE and GTK3. Anyway after a huge upgrade I lost the ability to load my pamac-gtk gui. Using the command line they were talking about an error in programming. I tried re-installing the programs but nothing worked. I removed pamac-gtk, which is dependent on GTK4, and replaced it with pamac-gtk3. I got the GUI back. Most of the time I do my upgrades with pacman at the command line. I got it fixed for my purposes but I think something went wrong with some programming along the line. I have it repaired for my needs. I hope when I try to go back to pamac-gtk again in the future it is working better. I have Manjaro on this computer but very seldom use it. I have it on another computer also and use it all the time.

Stable update [2023-07-10]

Known issues and solutions

▼ Pamac GUI theme does not match theme for Xfce

pamac-gtk 11.0.1 uses Gtk 4 that is not supported by Xfce
user can replace pamac-gtk with pamac-gtk3

pamac install pamac-gtk3
1 Like