Pacman says “there is nothing to do”

My laptop won’t do any upgrade.
Pacman says “there is nothing to do”
Pamac says my system is up to date.
I know it is not. For instance my firefox is version 79 while the latest version is 81.
What can I do?

Are you using the 32-bit version of Manjaro?

I have to add extra text after that question, otherwise the forum won’t let me post it.

No. I use 64bit Manjaro XCFS

Have you updated your mirrors recently?

I just did it now. Unfortunately no difference. Pamac still say that the system is up to date.

Have you tried using pacman instead (sudo pacman -Syyu)? Pamac has been getting a lot of updates recently.

Yes I did, after sudo pacman-mirrors.
pacman says “there is nothing to do”

Problem solved. With “sudo pacman-mirrors -g” I updated my mirror list.
Now pacman -Suyy is doing its job.
Thanks, @drhoopoe and @Feakster

1 Like

pamac has this thing built into its gui with a fancy button and stuff.
but for this usually I do (and remember … always use 2 'y’s when touching mirrors)

sudo pacman-mirrors -f && sudo pacman -Syyu

Pacman cant sort mirrors for you … just refresh and sync from the one you have selected … so it was doing its job before just fine as well.

1 Like