Pacman dysfunctional due 'error while loading shared libraries:'

Hey all,

Please forgive me for asking something that will be obvious for a seasoned user.

I have an issue very similar to Pacman: error while loading shared libraries: after updating openssl, however, the proposed solution doesn’t work; i.e.: After downloading openssl-3.1.4-1-x86_64.pkg.tar.zst, and extracting from it and chown it to root:root, chmod it 777 and moving it to /usr/lib/, pacman still doesn’t do anything/throws the same error (with everything, even a mere pacman --version).

Hardware is a newly bought PinePhone Pro, if that matters.

Already many thanks in advance!

It matters that if you followed the link in that thread verbatim you downloaded the package for x86_64 (while your system is ARM).
Not to mention the version, but you probably gathered that from looking at what the mirror was providing.

1 Like

Isn’t Pine Phone an ARM device?

Should the proper file be : openssl-3.1.4-1-aarch64.pkg.tar.xz ?

It should install correctly via the package manager, I would think.

Hey cscs,

Many thanks for the reply.

This does make sense, but it is not obvious to me which tar I should then download – if at all.

Yes, I downloaded another version of the tar (the one I list in the question).


Pine devices is suffering for the time being … unfortunately … to few hands after the locomotive went on a walk-about.

Hey jrichards326,

Many thanks for the reply.

Probably that or a similar tar would be better, but I can’t install it via the package manager, since it doesn’t function anymore (even a mere pacman --version throws the aforementioned error). Any suggestions on where to find the latest stable openssl release for ARM devices?

or on any other of the mirrors.

1 Like

Hey All,

Following the other solution at the issue for Pacman: error while loading shared libraries: works here as well, be it combined with ARM-specific software, as pointed out.

Many thanks for the helpful and fast responses!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.