Overheated ASUS Zenbook UX582LR causes immediate shutdowns

I’ve switched to Manjaro (currently 21.3.6, Linux kernel 5.15) for a couple of months ago and my ASUS Zenbook UX582LR started to overheat when using some heavy programs like Android Studio, running a heavy build script or even a simple meeting through Microsoft Teams (through Chrome). This overheating causes immediate shutdowns and journalctl doesn’t log anything about this.

I’ve managed to figure this out:

  1. No fans run properly! They run too slow, or doesn’t run at all. I can only feel some air flowing from the vent to the left (CPU fan), barely anything from the vent to the right (which I can when booting Windows).
  2. I haven’t found a way to control my fans more than toggling between “auto” and “full” using bash -c "echo 0 > /sys/devices/platform/asus-nb-wmi/hwmon/hwmon[[:print:]]*/pwm1_enable" but this only controls the CPU fan. So I wrote a script on my own that toggles this depending on CPU temperature, but it isn’t enough to prevent immediate shutdowns.

$ inxi -v7azy output:

  Kernel: 5.15.57-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=fbfeec65-2ac2-4793-90fe-4a9e8e13c208 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3 mem_sleep_default=deep
  Desktop: GNOME v: 42.3.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM
    v: 42.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: ZenBook Pro Duo UX582LR_UX582LR v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UX582LR v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: UX582LR.305 date: 12/30/2021
  ID-1: BAT0 charge: 79.1 Wh (100.0%) condition: 79.1/92.6 Wh (85.4%)
    volts: 15.9 min: 15.9 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 17
  Device-1: hid-0018:04F3:2C23.0002-battery model: ELAN9009:00 04F3:2C23
    serial: N/A charge: N/A status: N/A
  Device-2: hid-0018:04F3:2C56.0001-battery model: ELAN9008:00 04F3:2C56
    serial: N/A charge: N/A status: N/A
  Device-3: hidpp_battery_2 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 31.11 GiB used: 14.05 GiB (45.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7-10870H bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165)
    stepping: 2 microcode: 0xF0
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1355 high: 3386 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 3286
    4: 2424 5: 2311 6: 1089 7: 903 8: 800 9: 900 10: 866 11: 800 12: 800
    13: 800 14: 800 15: 3386 16: 917 bogomips: 70421
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat
    pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: Split huge pages
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: none off: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
    chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: none off: HDMI-A-1
    empty: none bus-ID: 01:00.0 chip-ID: 10de:249d class-ID: 0300
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-1.1:4 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-4: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-9:3 chip-ID: 13d3:56eb class-ID: fe01 serial: <filter>
  Display: x11 server: X.org v: with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled pos: primary
    model: Samsung LC49G95T serial: <filter> built: 2245 res: 5120x1440 hz: 60
    dpi: 130048 gamma: 1.2 size: 1x1mm (0.04x0.04") diag: 1239mm (48.8")
    modes: max: 3840x1080 min: 640x480
  Monitor-2: eDP-1 mapped: eDP-1-1 note: disabled model: Samsung 0x4143
    built: 2019 res: 5120x1440 dpi: 284 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 3840x2160
  OpenGL: renderer: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2 v: 4.6.0
    NVIDIA 515.57 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    bus-ID: 1-1.1:4 v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    chip-ID: 046d:082d bus-ID: 00:1f.3 class-ID: 0102 chip-ID: 8086:06c8
    serial: <filter> class-ID: 0403
  Device-2: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:228b class-ID: 0403
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.15.57-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-5d6d1896-13e1-43d0-a12a-1e8231a9de6d maj-min: 254:0
    type: LUKS dm: dm-0 size: 202.48 GiB
  p-1: nvme0n1p9 maj-min: 259:9 size: 202.48 GiB
  Message: No RAID data found.
  Local Storage: total: 953.87 GiB used: 52.76 GiB (5.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB1T0HBLR-00000 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: EXF7201Q temp: 47.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 146.48 GiB size: 143.13 GiB (97.71%) used: 21.65 GiB
    (15.1%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A
    uuid: fbfeec65-2ac2-4793-90fe-4a9e8e13c208
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 316 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p10 maj-min: 259:10 label: NO_LABEL
    uuid: D963-2401
  ID-3: /home raw-size: 202.48 GiB size: 198.24 GiB (97.91%) used: 31.09 GiB
    (15.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5d6d1896-13e1-43d0-a12a-1e8231a9de6d label: N/A
    uuid: 2965870c-7bfe-40de-8269-dc80952b710e
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.62 GiB used: 17.8 MiB (0.1%)
    priority: -2 dev: /dev/nvme0n1p8 maj-min: 259:8 label: N/A
    uuid: 4f0bf102-2b42-4476-9948-19d54608f719
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 260 MiB fs: vfat label: SYSTEM
    uuid: 0CA1-04AA
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 512.97 GiB fs: ntfs label: OS
    uuid: 1068A2D568A2B8BC
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 1000 MiB fs: ntfs
    label: RECOVERY uuid: 2AD88368D883315D
  ID-5: /dev/nvme0n1p5 maj-min: 259:5 size: 200 MiB fs: vfat label: MYASUS
    uuid: AC40-E837
  ID-6: /dev/nvme0n1p6 maj-min: 259:6 size: 74.38 GiB fs: ext4 label: N/A
    uuid: 3fb5114f-a86f-4065-8263-167328af8406
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Realtek RTS5411 Hub ports: 3 rev: 2.1 speed: 480 Mb/s
    chip-ID: 0bda:5411 class-ID: 0900
  Device-1: 1-1.1:4 info: Logitech HD Pro Webcam C920 type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  Device-2: 1-9:3 info: IMC Networks USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:56eb class-ID: fe01 serial: <filter>
  Device-3: 1-14:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-1:2 info: Realtek Hub ports: 2 rev: 3.2 speed: 5 Gb/s
    chip-ID: 0bda:0411 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 57.0 C pch: 70.0 C mobo: N/A gpu: nvidia
    temp: 55 C
  Fan Speeds (RPM): cpu: 1400
  Processes: 550 Uptime: 1d 3h 57m wakeups: 1045 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
  Packages: 1283 pacman: 1270 lib: 319 flatpak: 0 snap: 13 Shell: Zsh v: 5.9
  running-in: terminator inxi: 3.3.20

$ mhwd -li output:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI

$ sensors output:

Adapter: ISA adapter
Package id 0:  +56.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +51.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +55.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +54.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +52.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 6:        +53.0°C  (high = +100.0°C, crit = +100.0°C)
Core 7:        +53.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +55.0°C  

Adapter: Virtual device
temp1:        +68.0°C  

Adapter: ACPI interface
in0:          15.94 V  

Adapter: ISA adapter
cpu_fan:     1400 RPM

Adapter: PCI adapter
Composite:    +46.9°C  (low  = -273.1°C, high = +83.8°C)
                       (crit = +84.8°C)
Sensor 1:     +46.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +43.9°C  (low  = -273.1°C, high = +65261.8°C)

Adapter: ACPI interface
temp1:        +54.0°C  (crit = +103.0°C)

Anyone with some decent input on how to solve this would be much appreciated!

Did you notice this after recent updates?

If so, I’m shooting in the dark, since kernel 5.15.57 introduced a shutdown/reboot bug, which might be interrelated to power/ACPI.

This wouldn’t be the first time, since a few months ago users faced a nasty issue with an update to the kernel 5.15.x series in which it quite literally cooked their laptops, because trying to suspend would stop all the fans, but leave the CPU running. Their laptops would “sound” and “appear” to be suspended, meanwhile their CPUs were running hot without a fan to keep them cool. (I was one of those victims. Some who were hit harder had their laptops in bags during travel, which is even worse.)


Have you dusted it recently?

1 Like

No, it has never worked with Manjaro. I’ve tried different kernels as well; 5.17, 5.18 och 5.19. None of them worked at the time.

The laptop was 6 months old when first trying Manjaro and the problem appeared directly. The fans run normally when booting Windows 10.

My issue seems to be related to Asus_nb_wmi Dual Fan control Asus ROG G53SW but there’s no solution there. asus_fan isn’t working for me.

Because the model you have is not in the compatibility list. See on their project page GitHub - daringer/asus-fan: Kernel module to get/set (both) fan speed(s) on ASUS Zenbooks

A newer project, by someone else, can be seen on GitHub - dominiksalvet/asus-fan-control: Fan control for ASUS devices running Linux and maybe is worth contacting them both and see how you can get your model in the compatibility list because they can probably deal with all the UX5 classes of those laptops if there is someone to provide the info they need.


I’ve tried asus-fan-control/contributing.md at master · dominiksalvet/asus-fan-control · GitHub and used afc-scout to find my addresses.

$ sudo FALLBACK_ADDRS='1335 1431' FALLBACK_TEMPS='45 50 55 60 65 70 75 80' asus-fan-control set-temps default

But it has no effect. No error, no nothing. I could open an issue though, the author seems to be fairly active. Thank you for your response.

You might have to add those values to this file asus-fan-control/models at master · dominiksalvet/asus-fan-control · GitHub with the model, then compile it again …

Tried modifying the models file. There’s nothing to compile though. But it doesn’t work even when it tell me it “recognizes” my model.

There’s some mentions that AFC doesn’t work for newer Intel models. I have a feeling my laptop is one of them.

I guess I have to wait for a kernel update for my fans to run normally. What really seems to reduce the symptoms for now is AUR (en) - auto-cpufreq to optimize my CPU speeds. This reduced my severe CPU temp peaks by a lot so hopefully my immediate shutdowns will stop.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.