Over 250GB available BUT not enough space error

Familiarize yourself with :point_down:

1 Like

does that mean you wanna tell me mounting an external drive in /home is responsible for my problem?
because I’ve been using this a very long time and the error just appears now…

Then, run:

sudo du --human-readable /


df --human-readable /

…again, to see if it’s better. Provide the output here, if you will.

df --human-readable /                                                                                                                                                                               ✔ 
Filesystem                                             Size  Used Avail Use% Mounted on
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7  915G  904G  8,6G 100% /

OK, this looks like a LUKS encrypted system/container and I know nothing 'bout that, so I is out.


1 Like


This whole thread reminds me of what is referred as an xy problem - that is you experience a problem and you have tried to fix it but the fix didn’t work and now you ask for help on the fix that didn’t work.

I am fairly certain you issue is cause by some circular mount loop so data which is expected to be elsewhere is still on the partition - that is entirely possible.

please provide the output from


and the output from

cat /etc/fstab

and the output from

lsblk -a

I saw earlier you have several snap loops mounted - that indicates you have some snaps installed which can cause your disk space to go haywire.

 sudo snap list
 sudo snap remove <pkg-name>

List all snap related services and sockets

systemctl list-unit-files | grep snap

Then stop and disable the services

systemctl disable --now <some-snap.service>

Then remove all snap related packages from the system - when that is done you look for

For reference:

huh? please tell me what I am doing wrong! Sorry, just have no idead whats happening now.

mount                                                                                                                                                                                               ✔ 
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=8113324k,nr_inodes=2028331,mode=755,inode64)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755,inode64)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 on / type btrfs (rw,relatime,ssd,discard=async,space_cache=v2,subvolid=256,subvol=/@)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,inode64)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursiveprot)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=14162)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
/var/lib/snapd/snaps/bare_5.snap on /var/lib/snapd/snap/bare/5 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/gnome-3-28-1804_161.snap on /var/lib/snapd/snap/gnome-3-28-1804/161 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/core18_2654.snap on /var/lib/snapd/snap/core18/2654 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/gtk-common-themes_1535.snap on /var/lib/snapd/snap/gtk-common-themes/1535 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/skype_240.snap on /var/lib/snapd/snap/skype/240 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/snapd_17883.snap on /var/lib/snapd/snap/snapd/17883 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/skype_238.snap on /var/lib/snapd/snap/skype/238 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/var/lib/snapd/snaps/core18_2632.snap on /var/lib/snapd/snap/core18/2632 type squashfs (ro,nodev,relatime,errors=continue,x-gdu.hide,x-gvfs-hide)
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 on /home type btrfs (rw,relatime,ssd,discard=async,space_cache=v2,subvolid=257,subvol=/@home)
tmpfs on /tmp type tmpfs (rw,noatime,inode64)
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 on /var/log type btrfs (rw,relatime,ssd,discard=async,space_cache=v2,subvolid=259,subvol=/@log)
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 on /var/cache type btrfs (rw,relatime,ssd,discard=async,space_cache=v2,subvolid=258,subvol=/@cache)
/dev/nvme0n1p1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1625864k,nr_inodes=406466,mode=700,uid=1000,gid=1000,inode64)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
portal on /run/user/1000/doc type fuse.portal (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
cat /etc/fstab                                                                                                                                                                                      ✔ 
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=8029-F717                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 /              btrfs   subvol=/@,defaults,discard=async,ssd 0 0
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 /home          btrfs   subvol=/@home,defaults,discard=async,ssd 0 0
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 /var/cache     btrfs   subvol=/@cache,defaults,discard=async,ssd 0 0
/dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 /var/log       btrfs   subvol=/@log,defaults,discard=async,ssd 0 0
/dev/mapper/luks-dbf4cdbb-fe19-48b3-b192-27fb7c918ec4 swap           swap    defaults,noatime 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
/dev/disk/by-id/wwn-0x5000c5003516d964-part2 /home/jellyfin/external\040drives/LaCie\0403TB auto nosuid,nodev,nofail,x-gvfs-show 0 0
lsblk -a                                                                                                                                                                                            ✔ 
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
loop0                                           7:0    0     4K  1 loop  /var/lib/snapd/snap/bare/5
loop1                                           7:1    0 141,6M  1 loop  /var/lib/snapd/snap/skype/240
loop2                                           7:2    0  91,7M  1 loop  /var/lib/snapd/snap/gtk-common-themes/1535
loop3                                           7:3    0 141,5M  1 loop  /var/lib/snapd/snap/skype/238
loop4                                           7:4    0  55,6M  1 loop  /var/lib/snapd/snap/core18/2632
loop5                                           7:5    0  49,6M  1 loop  /var/lib/snapd/snap/snapd/17883
loop6                                           7:6    0 164,8M  1 loop  /var/lib/snapd/snap/gnome-3-28-1804/161
loop7                                           7:7    0  55,6M  1 loop  /var/lib/snapd/snap/core18/2654
loop8                                           7:8    0     0B  0 loop  
nvme0n1                                       259:0    0 931,5G  0 disk  
├─nvme0n1p1                                   259:1    0   300M  0 part  /boot/efi
├─nvme0n1p2                                   259:2    0 914,2G  0 part  
│ └─luks-25e682ef-5af2-4547-b873-61c4a2369cc7 254:0    0 914,2G  0 crypt /var/cache
│                                                                        /var/log
│                                                                        /home
│                                                                        /
└─nvme0n1p3                                   259:3    0  17,1G  0 part  
  └─luks-dbf4cdbb-fe19-48b3-b192-27fb7c918ec4 254:1    0  17,1G  0 crypt [SWAP]
sudo snap list                                                                                                                                                                                      ✔ 
[sudo] password for alexander: 
Name               Version                     Rev    Tracking       Publisher   Notes
bare               1.0                         5      latest/stable  canonical✓  base
core18             20221205                    2654   latest/stable  canonical✓  base
gnome-3-28-1804    3.28.0-19-g98f9e67.98f9e67  161    latest/stable  canonical✓  -
gtk-common-themes  0.1-81-g442e511             1535   latest/stable  canonical✓  -
skype                      240    latest/stable  skype✓      -
snapd              2.57.6                      17883  latest/stable  canonical✓  snapd
systemctl list-unit-files | grep snap                                                                                                                                                               ✔ 
var-lib-snapd-snap-bare-5.mount                                                     enabled         disabled
var-lib-snapd-snap-core18-2632.mount                                                enabled         disabled
var-lib-snapd-snap-core18-2654.mount                                                enabled         disabled
var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-161.mount                               enabled         disabled
var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1535.mount                               enabled         disabled
var-lib-snapd-snap-skype-238.mount                                                  enabled         disabled
var-lib-snapd-snap-skype-240.mount                                                  enabled         disabled
var-lib-snapd-snap-snapd-17883.mount                                                enabled         disabled
snapd.aa-prompt-listener.service                                                    disabled        disabled
snapd.apparmor.service                                                              enabled         disabled
snapd.failure.service                                                               static          -
snapd.seeded.service                                                                disabled        disabled
snapd.service                                                                       enabled         disabled
snapper-boot.service                                                                static          -
snapper-cleanup.service                                                             static          -
snapper-timeline.service                                                            static          -
snapperd.service                                                                    static          -
snapd.socket                                                                        disabled        disabled
snapper-boot.timer                                                                  disabled        disabled
snapper-cleanup.timer                                                               disabled        disabled
snapper-timeline.timer                                                              disabled        disabled

Just a thought… did you actually delete or did you move it to trash bin? Check your trash bin :wink:

To add here. Search for Trash folders:

sudo find / -type d -readable \( -wholename "*[Tt]rash/files" -or -wholename "*.[Tt]rash-1000/files" \) 2>/dev/null

And check them for “deleted” files manually.

Could you please detach your external storage and keep it detached.

Then post the output of

sudo btrfs filesystem usage /
sudo btrfs filesystem usage /                                                                                                                                                                     1 ✘ 
[sudo] password for alexander: 
    Device size:		 914.16GiB
    Device allocated:		 907.20GiB
    Device unallocated:		   6.96GiB
    Device missing:		     0.00B
    Device slack:		   2.50KiB
    Used:			 902.95GiB
    Free (estimated):		   8.57GiB	(min: 5.09GiB)
    Free (statfs, df):		   8.57GiB
    Data ratio:			      1.00
    Metadata ratio:		      2.00
    Global reserve:		 512.00MiB	(used: 0.00B)
    Multiple profiles:		        no

Data,single: Size:899.13GiB, Used:897.52GiB (99.82%)
   /dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7	 899.13GiB

Metadata,DUP: Size:4.00GiB, Used:2.71GiB (67.81%)
   /dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7	   8.00GiB

System,DUP: Size:32.00MiB, Used:160.00KiB (0.49%)
   /dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7	  64.00MiB

   /dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7	   6.96GiB

In any case the file system clearly states you have used 897GB out of 899GB.

I have no idea - it - kind’a - remind me why I am not fond of btrfs - I remember btrfs did that stunt on me many years back - and I really don’t like it.

My system - for the moment - runs with btrfs - but I have weird issues and freezes where my hdd activity light goes steady blinking like something is terribly wrong - it takes a long time before it settles.

You clearly state that you have moved data off the disk
You have emptied the trash - either in Nautilus or manually like described above

rm -rf ~/.local/share/Trash

Perhaps it is worth rechecking your trash

It is worth understanding how an SSD handles files within memory cells.

I am guessing now

  • I really have no idea
  • your luks encrypted volume hides the content for prying eyes so the underlying SSD only knows of one big container
  • what is inside the container is handled by another layer
  • so the SSD goes
  • in cell terms - full and somewhere in the communication between the elements
    • the ssd controller
    • the kernel
    • the luks container
    • the btrfs filesystem inside the container
      • go haywire
  • the controller says
    • I am full
  • the filesystem says
    • no you are not
  • who wins?

btrfs filesystem defragment

hmm… okay :-/
so what is your opionion? use ext4 instead?
with my external drive detached I am now running another balance and will see where that takes me… after that I’ll try de fragmentation and post my results here.

anyways: I really thank you for your time and help!!

I know what I am going to do the next 15 minutes - I am going to get rid of btrfs for - I don’t have count any more - 20th time :slight_smile:

I am going for a

buildiso -p kde -b unstable -k linux61

Just to check on some last info that is missing after reading this whole thread:
Can you perform:

  1. Mount the btrfs root, which is inside the luks container, with:
    systemd-mount /dev/mapper/luks-25e682ef-5af2-4547-b873-61c4a2369cc7 /tmp/bare_btrfs_root
  2. Then post the output of:
    sudo ls -la /tmp/bare_btrfs_root
  3. And then to unmount it again:
    systemd-umount /tmp/bare_btrfs_root

happy to do that:

sudo ls -la /tmp/bare_btrfs_root                                                                                                                                                                    ✔ 
[sudo] password for alexander: 
total 16
drwxr-xr-x  1 root root  62 14. Sep 19:12 .
drwxrwxrwt 28 root root 820 20. Dez 14:31 ..
drwxr-xr-x  1 root root 252  2. Nov 19:38 @
drwxr-xr-x  1 root root 174 15. Sep 12:39 @cache
drwxr-xr-x  1 root root  34 14. Sep 20:26 @home
drwxr-xr-x  1 root root 190 20. Dez 12:20 @log
drwxr-xr-x  1 root root 210 18. Dez 21:35 timeshift-btrfs

I have a theory on orphaned data - perhaps snapshots - but I have no idea how to verify it.

I noted in the list-unit-files output above that you have some snapper services running.

Have they produced something which is taking up space?

I ran an internet search and it seems that free space going AWOL is happening

how to recover lost space on btrfs after moving huge amounts of data

Defrag appears to magnify the issue

Some had issues with Docker on btrfs which exhaust diskspace - perhaps snaps does too?

An 8y old thread

Could you repeat the steps again with the command in (2) replaced by:

  1. sudo ls -lar /tmp/bare_btrfs_root/timeshift-btrfs
  2. sudo du --human-readable /tmp/bare_btrfs_root/timeshift-btrfs

Just to rule out stuff…

Yup using another search engine as yours, i found btrfs and missing free space
(note the first comment on it)

Disclaimer that thread is 10 years old :rofl: