Outdated iso images - First update

Hi

I want to install Manjaro, but it looks like the current iso images are out of date (released 2-3 months ago). As you might have guessed: they’re unusable, unless there’s some sort of trick that I don’t know of.

Is there a way to get a refreshed iso that’s also stable?

Thanks in advance.

sorry for my tag in [stable update] with your first post, (bad topic)

“unusable” ? Normally not, but you tell us which iso kde ?

An iso update is coming soon (now is rc5 2020-08-28 for kde) - Exists also some beta iso, for example

Yes, it’s kde.

I actually tried it (20.0.3) and it broke because there were so many packages to update (~1GB).

ok, iso is good but update package is difficult. It’s a another problem and with kde it’s normal to have 1…2 updates of 1Go in one month
Use last rc5 change nothing

1 Like

I doubt your system broke because the update was ‘big’.

You can blame me for being inexperienced, that’s why I’m posting here.

I’d advise to update the kernel first (maybe 5.7 or 5.8) before updating other programs.

As far as I know, the kernel used in the current manjaro kde ISO is unsupported right now. At least that’s what it said when I did a fresh install. I’ve had some laptop intel CPU’s (namely, i7 10510U) freeze up randomly with that particular kernel version, still can’t figure out why.

1 Like

After updating the kernel, is there a specific order for updating other packages that you’d recommend? Or is it ineffective?

An auto-update should take care of things on it’s own with no further issues, most likely. Maybe you could do an auto driver update first and then the programs if you want a particular order - never hurts to have the drivers installed first.

1 Like

How interesting.

Thank you for your reply! :smiley:

Make your update in konsole and copy here error if exists

pacmac update or sudo pacman -Syu
if software asks a Yes/No : validate without entering an answer (Y/n: Yes is the default - y/N: No is the default).

is a partial update :sob:

Will remember to do that.

Ok so I tried Gnome (20.0.3) I thought it was a good idea to upgrade the system on the live USB before installing it on my machine. Everything was going fine until it started upgrading/installing. It just hard freezed in the middle of installation phase and it’s been like this for about 10 minutes till now. Idk if there is anything I can do here except trying again.

Dont try to update the live system.
Just install … then update your system.
If you want this all done by the time you get to your installed desktop…
Use Architect.
(the same goes for funny hardware or needing a specific kernel, etc. Just use Architect)

I see. So this is how things go here…

I mean … theres no point to updating the live system.
And … it might not be very successful given that its not a real filesystem and all.

Most of the times it’s better to keep the live usb intact, with no updates - this way you won’t break the installer. Then you install it on your PC, then update from the already installed system on your HDD/SSD. The updates are faster (it can write data faster than an usb), you don’t risk breaking stuff as much - and in the worst case scenario, if it goes bad you just pop the USB back in and reinstall.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.