Failed to add new printer

Hello everyone,

I am trying to add/install the following printer I have at home: Brother MFC-L3770CDW
I tried installing it via the Manjaro settings under printer. The printer is found with this address: BRW30C9AB0AAC8E. When clicking on the “Add” button it just fails to add a new printer. I have re-installed cups, and manually started the services but nothing seems to fix it.

Do you have any suggestions about where to start to move forward?

Thank you for your time and help!

/Thibaut

Just making sure:
Have you installed the drivers from AUR brother-mfc-l3770cdw 1.0.2-0 ?
here is the AUR page AUR (en) - brother-mfc-l3770cdw
You can also install from Pamac

I had not done that indeed. Usually I just go to “Add printer” and then it detects it on the WIFI network and search for its driver on its own when selected.
I have now installed the drivers from the AUR repository. It makes this printer model show on the printers page but off course it is not configured. I saw that there is a “Location” tab in the printer’s parameters. Should that be set to the printer MAC address?

Hi @thiri ,
Please, take a look at this two post, which can solve the problem.
In the first read what @mike27 posted.
Brother MFC985-J985DW printer not scanning

In the second read what @linux4all posted.
Brother Wifi Network Printer - Detected But Not Printing - #4 by Terence64w

Hope it help, regards.

Hi @j8a,

Thank you for your answer. I had a quick look at @mike27 's answer and I am not sure to have the required configuration for doing that.

sudo brsaneconfig4 -a name=MFC-J985DW imodel=MFC-J985DW ip=192.168.1.155

I cannot find an IP address for my printer and only have a MAC address.

Regarding your second suggestion, from @linux4all, I have tried that and it still does not work …

How could I start racking this issue down? I had this printer installed on my previous computer, also running MANJARO and it worked just fine …

Hi @thiri ,
The first post suggest to update your cups after an update.
`org.cups.cupsd.{service,socket,path}` not found - #7 by Hipster

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

Could you run the above commands in order to see whether is working your printer?
Otherwise, you can try to install the printer from CUPS from the browser.

http://localhost:631/admin

Regards

Hi @j8a,

Thank you for your reply. After trying these:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

I actually get the following. Which I had in the past and resolved by just re-installing cups. Am I doing something terribly wrong here?

Failed to disable unit: Unit file org.cups.cupsd.socket does not exist.
Failed to disable unit: Unit file org.cups.cupsd.service does not exist.
Failed to disable unit: Unit file org.cups.cupsd.path does not exist.

Hi @thiri
No, whether these three messages are the ones for the first three commands.
I expect that the other three commands gave you no messages which is great.

Try to install the printer from CUPS as I posted before in order to try to solve the problem.

Regards

Dear @j8a,

Thank you for following-up. I have now added the printer via the CUPS web interface:

http://localhost:631/admin

It worked and I have printed a test page just fine. Thank you for taking the time to help me out. I have marked your last answer as the solution.

Best regards,

/Thibaut

The naming has changed quite a while ago - the older guides are now invalid in that respect.
it’s now just:
cups.socket
and
cups.service
(not org.cups.cupsd.socket or org.cups.cupsd.service)

You also need only either one active - not both.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.