OpenGL renderer is llvm besides having a dedicated Nvidia GPU

I am having GPU Problems that I can’t seem to fix myself. I have a Nvidia GT 1030 GPU installed in my PC and am using the video-nvidia-390xx drivers. Since support for these drivers seems to have been dropped in the latest kernel, I switched to kernel 5.4 LTS. Nonetheless, when I run glinfo, the default OpenGl renderer seems to be llvm:

$ glinfo | grep RENDERER
GL_RENDERER: llvmpipe (LLVM 11.0.1, 256 bits)

So far, none of the suggested solutions I found on this forum have worked for me.


Like what solution, this for instance ?

If you do not have video-vesa installed, then drop the video-nvidia-390xx and install (trough mhwd) the video-nvidia driver.
In short, you will have to:

sudo mhwd -r pci video-vesa
sudo mhwd -r pci video-nvidia-390xx
sudo mhwd -i pci video-nvidia

Thanks for your response.

I red the mentioned thread and because of it I switched to kernel 5.4 (from 5.10).
Should I try the suggested steps of uninstalling any nvidia named program and reinstalling them?

I tried your suggested commands but ran into an error:

$ sudo mhwd -i pci video-nvidia
Error: config ‘video-nvidia’ does not exist!

What is the output of mhwd -l from terminal ?
Also mhwd -li
and inxi -Fazy

mhwd -l:

0000:01:00.0 (0300:10de:1d01) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

mhwd -li:

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-390xx            2020.11.30               false            PCI

Warning: No installed USB configs!

inxi -Fazy:

  Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=5b93264e-4bce-4c99-80b7-482a56d2d9e2 rw quiet apparmor=1 
  security=apparmor resume=UUID=0a4fb2c9-e835-4933-aace-1e3c7622a4f6 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: B85-PRO GAMER v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 2103 date: 08/19/2014 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: Quad Core model: Intel Core i5-4690 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 27947 
  Speed: 1394 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1394 2: 1376 
  3: 1393 4: 1392 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: ZOTAC driver: nvidia 
  v: 390.141 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1d01 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.7x13.5") 
  s-diag: 692mm (27.3") 
  Monitor-1: HDMI-0 res: 2560x1440 hz: 60 dpi: 109 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.3 
  compat-v: 3.1 direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA GP108 High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb8 
  Device-3: Sennheiser Sennheiser PC 8.2 USB type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-10.3:4 chip ID: 1395:0099 
  serial: <filter> 
  Sound Server: ALSA v: k5.4.89-1-MANJARO 
  Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.36 TiB used: 114.23 GiB (8.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WD1003FZEX-00MK2A0 size: 931.51 GiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A01 
  ID-1: / raw size: 448.4 GiB size: 440.36 GiB (98.21%) 
  used: 114.23 GiB (25.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.07 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 42 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
  Processes: 215 Uptime: 1h 28m wakeups: 6 Memory: 15.58 GiB 
  used: 3.47 GiB (22.3%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: 1660 pacman: 1653 lib: 430 flatpak: 0 snap: 7 Shell: Bash v: 5.1.0 
  running in: tilix inxi: 3.2.02

Ok, not sure, but it seems the

is only supported by the video-nvidia-390xx driver. I wonder what is the content of /etc/X11/mhwd.d/nvidia.conf

and if /etc/modprobe.d/mhwd-gpu.conf has this content in it:

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

and if the file /etc/modules-load.d/mhwd-gpu.conf has this:



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.141  (dvs-builder@U64-P08-12)  Mon Dec 28 16:12:07 UTC 2020

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.141  (dvs-builder@U64-P08-12)  Mon Dec 28 16:13:08 UTC 2020

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS BE27A"
    HorizSync       30.0 - 120.0
    VertRefresh     49.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 1030"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

/etc/modprobe.d/mhwd-gpu.conf has the said content in it, /etc/modules-load.d/mhwd-gpu.conf does too.

Looks good to me overall, but not quite sure what would be wrong on your end.
Run this command and reboot:
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

maybe force the reinstall of the driver with:
sudo mhwd -f -i pci video-nvidia-390xx

The device seems to be supported by the latest driver.

@jayce.m Please reinstall mhwd-db by running sudo pacman -Syu mhwd-db, and check if mhwd -l offers video-nvidia. If it does, remove video-nvidia-390xx, and install video-nvidia.

1 Like

@pobrn thank you, that did the trick :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.