Only Dummy Output available in laptop

Hello, I recently switched to linux from windows but haven’t managed to get sound working. I have experience with Deb distros but this is my first arch based distro.
My current kernel is 5.10 (I tried a few different ones to see if it would fix the issue) and I’ve done all the fixes I found online, but with no success. Sometimes the Dummy Output disappears but I still only find HDMI output (I don’t have a device connected to HDMI) and still no sound.
Here are some outputs that might be useful:

[me@me-voomexcellence ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[me@me-voomexcellence ~]$  aplay -L | grep PCH
    HDA Intel PCH, HDMI 0
    HDA Intel PCH, HDMI 1
    HDA Intel PCH, HDMI 2
    HDA Intel PCH, HDMI 3
    HDA Intel PCH, HDMI 4
    HDA Intel PCH
[me@me-voomexcellence ~]$ 

Thanks a lot in advance!

Oh, and I forgot my inxi output.

[me@me-voomexcellence ~]$ inxi --admin --verbosity=7 --filter --width
  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=3ed8311b-fdda-4b2e-b222-3fb72f6f2a2e rw nouveau.nomodeset=0 quiet
  apparmor=1 security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop Mobo: N/A model: N/A serial: <filter> UEFI: American Megatrends
  v: $(AMI_ROM_NAME)_T$(2021)$(01)$(23)$(17)$(30) date: 01/23/2021
  ID-1: BAT0 charge: 30.4 Wh (100.0%) condition: 30.4/30.4 Wh (100.0%)
  volts: 7.6 min: N/A model: GLK MRD Li-ion Battery type: Li-ion
  serial: <filter> status: Discharging
  RAM: total: 7.59 GiB used: 1.63 GiB (21.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: Intel Celeron N4020 bits: 64 type: MCP
  arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 8 microcode: 1A
  cache: L2: 4 MiB bogomips: 4378
  Speed: 2465 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 2465 2: 2427
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
  arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
  flexpriority fpu fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida intel_pt
  lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl
  nx pae pat pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts
  rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep ss ssbd
  sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer tsc_known_freq umip vme vmx vnmi vpid x2apic xgetbv1
  xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
  bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
  Device-2: Microdia HP Integrated Webcam type: USB driver: uvcvideo
  bus-ID: 1-7:3 chip-ID: 0c45:6321 class-ID: 0e02
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
  bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0401
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Message: No device data found.
  IF-ID-1: wlp0s21f0u4i2 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB
  driver: btusb,rtl8xxxu bus-ID: 1-4:2 chip-ID: 0bda:b720 class-ID: e001
  serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 8 GiB (3.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 model: SSD 256GB size: 238.47 GiB block-size:
  physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
  rev: 4A0 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) used: 8 GiB (3.4%)
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 3ed8311b-fdda-4b2e-b222-3fb72f6f2a2e
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: 58F1-267E
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Realtek RTL8723BU 802.11b/g/n WLAN Adapter
  type: Bluetooth driver: btusb,rtl8xxxu interfaces: 3 rev: 2.1
  speed: 480 Mb/s power: 500mA chip-ID: 0bda:b720 class-ID: e001
  serial: <filter>
  Device-2: 1-7:3 info: Microdia HP Integrated Webcam type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 0c45:6321 class-ID: 0e02
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 7 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 167 Uptime: 8m wakeups: 1 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: N/A Packages: pacman: 1060 lib: 306 flatpak: 0 Shell: Bash
  v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.08
[me@me-voomexcellence ~]$ 

Did you try reinstalling sof-firmware?

Take a look at

sof-firmware has been orphaned:

Package sof-firmware was previously marked as a dependency in 2 metapackages – manjaro-pulse and manjaro-pipewire

But sof-firmware is not a required dependency of either PulseAudio or PipeWire

Sound Open Firmware is required for Intel laptops to support digital array microphones in ALSA
Users on Intel laptops should change this package in pamac-manager by clicking on Mark as explicitly installed

Intel desktop systems might need Sound Open Firmware in the future when it supports use of onboard audio processing. But I do not know of any plans to add DSP support, so it is not likely to be happening soon

AMD Audio Co-Processor support for digital microphones is included in the kernel, so AMD systems do not require this package