On a newly installed Manjaro the printer will not print (CUPS) - Tar from old system possible?

I installed on a Lenovo Legion5 laptop Manjaro with KDE. Booting with KDE minimal image did not work. But this problem is solved.

Now the printer is installed and I can not print to a Samsung M2675FN printer. The printer starts
and the the job is purged. The printer is the same as an HP laser printer.

On my old Manjaro XFCE on an Lenovo Yoga laptop printing worked fine.

Is there a way to tar all old config files from my Yoga laptop and install it on the Legion5 laptop?

Maybe then it should work.

The queues are ready.
$ lpstat -a
M267x-287x-Series accepting requests since Wed Apr 20 09:34:44 2022
Samsung-M267x-287x accepting requests since Thu Apr 14 10:42:28 2022
Samsung-M267x-287x-Series accepting requests since Fri Apr 22 18:47:26 2022
Samsung-M267x-287x-Series-2 accepting requests since Sat Apr 23 17:09:48 2022

Thank you for your help, Franz

It should be enough to install the very same packages that you used to work with the printer on the Yoga laptop
and perhaps transfer the cups configuration from the old to the new
instead of creating it anew.
Just compare what you had to do with what you have now.

Just transferring will likely work - if you know what …
but then the package manager isn’t aware of what you did and you’ll have problems down the (time)line.

I know that sounds a bit silly
… “if you know what” …
but if you know - you can just install the proper packages
and if you don’t … well … then you don’t know for sure what to transfer and whether you caught all of it …

it’s by far not only about configuration files
you need the printer driver and ppd - and possibly more
if you have that in place - transferring the config might just work
not sure whether there is anything user specific (permissions, group membership) in it that would require adaptation

Do you have the /var/log/pacman.log from your Lenovo Yoga

There you will find what packages you installed

Do you have a backup of /etc from your Lenovo Yoga

This would be a good basis to compare configfiles

Do you use Timeshift or snapper ?

This would be a good idea in case you mess up :wink:

This looks relevant: CUPS/Printer-specific problems - ArchWiki

Thank you all for your help.

I have solved the problem.
It seems that long time ago I installed the Samsung printer driver on the old machine.
Now I copied all files from the old machine to the new machine.

pacman -Ql cups
cd /
tar --xz -cvf /tmp/cups.tar.xz ./etc/cups/ ./usr/lib/cups/ ./usr/share/cups/ ./var/spool/cups/ ./opt/samsung ./opt/smfp-common

And then I installed this tar image on the new machine.

Your link helped me the most. Thank you.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.