Okular does not load recent files/tabs on restart

Okular does not load recent files/tabs on restart as it did before.

Okular Version 21.08.0
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.10.60-1-MANJARO (64-bit)
Graphics Platform: X11

$ inxi --admin --verbosity=7 --filter --no-host --width 
System:
  Kernel: 5.10.60-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=a3d17ce4-9aaf-437d-a73a-439edc842272 rw quiet acpi_rev_override=1 
  pcie_port_pm=off resume=UUID=1a692f9b-337c-4cfa-81e9-a514be6aa511 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: Dell product: G3 3779 v: N/A serial: <filter> Chassis: 
  type: 10 serial: <filter> 
  Mobo: Dell model: 04R93M v: A00 serial: <filter> UEFI: Dell v: 1.2.1 
  date: 07/18/2018 
Battery:
  ID-1: BAT0 charge: 17.7 Wh (100.0%) condition: 17.7/56.0 Wh (31.6%) 
  volts: 17.1 min: 15.2 model: Samsung SDI DELL W7NKD87 type: Li-ion 
  serial: <filter> status: Full 
Memory:
  RAM: total: 15.49 GiB used: 6.39 GiB (41.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 9 MiB bogomips: 52815 
  Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Dell 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c20 class-ID: 0302 
  Device-3: Realtek Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-5:3 
  chip-ID: 0bda:568a class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.7x13.5") 
  s-diag: 693mm (27.3") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") 
  diag: 686mm (27") 
  OpenGL: renderer: NVIDIA GeForce GTX 1060 with Max-Q Design/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.60-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel 
  port: 5000 bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 3b:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp59s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> scope: link 
  IF-ID-1: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 2.05 TiB used: 321.3 GiB (15.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: SDM2 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: SK Hynix model: SC311 SATA 256GB 
  size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 0P10 scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 27.94 GiB size: 27.38 GiB (97.98%) used: 21.84 GiB (79.8%) 
  fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A 
  uuid: a3d17ce4-9aaf-437d-a73a-439edc842272 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: EFI 
  uuid: 45D5-9BC5 
  ID-3: /data raw-size: 559.16 GiB size: 549.38 GiB (98.25%) 
  used: 163.36 GiB (29.7%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: Data 
  uuid: 27bc111f-0627-4f8e-aad9-f5b08eb60e14 
  ID-4: /home raw-size: 193.15 GiB size: 189.12 GiB (97.91%) 
  used: 22.69 GiB (12.0%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: N/A 
  uuid: f19fe205-c411-40ff-b63a-165435acb85d 
  ID-5: /music raw-size: 745.06 GiB size: 732.36 GiB (98.30%) 
  used: 51.05 GiB (7.0%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: Music
  uuid: 04b74089-4a64-43f4-afa9-ffea7b6cb0b5
  ID-6: /var raw-size: 93.14 GiB size: 91.17 GiB (97.89%)
  used: 17.44 GiB (19.1%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: var
  uuid: a51c81a4-a4b9-422e-912f-e08a5c8d0d31
  ID-7: /video raw-size: 465.66 GiB size: 457.35 GiB (98.22%)
  used: 44.91 GiB (9.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: Video
  uuid: 821ea29a-ea1f-4aeb-8658-e293f9046d4b
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sdb4 maj-min: 8:20 label: N/A
  uuid: 1a692f9b-337c-4cfa-81e9-a514be6aa511
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:10 info: ASUSTek ASUS ROG GAMING MOUSE GX900
  type: Mouse,Keyboard driver: hid-generic,usbhid interfaces: 2 rev: 2.0
  speed: 12 Mb/s power: 100mA chip-ID: 0b05:1795 class-ID: 0301
  Device-2: 1-5:3 info: Realtek Integrated Webcam type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:568a
  class-ID: 0e02 serial: <filter>
  Device-3: 1-6:4 info: Realtek RTS5129 Card Reader Controller
  type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
  interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
  class-ID: ff00 serial: <filter>
  Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP)
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 8087:0aaa class-ID: e001
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 47 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 434 Uptime: 23h 32m wakeups: 11 Init: systemd v: 248
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1860
  pacman: 1854 lib: 446 flatpak: 0 snap: 6 Shell: Bash v: 5.1.8
  running-in: konsole inxi: 3.3.06
$ pamac search okular
okular                                                     [Установленные] 21.08.0-1                    extra
    Document Viewer

(p.s. | grep Installed is not applied, as something wrong with my locale settings. Установленные means Installed )

2 Likes

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. The output to pamac search okular | grep Installed would be helpful as well as you might have accidentally installed the snap / flatpak / AppImage version instead of the native version.

:+1:

P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.

1 Like

Information added.

1 Like

That all looks good…
So what you’re saying is that if you go to FileRecent the list is always empty???

:thinking:

No, as I said “Okular does not load recent files/tabs” (literally).
Before this time it remembered and loaded all the previous tabs of opened files even after system restart.
Now, on restart it opens empty (no tabs) and “Recent” section contains only some recent files - not all.

Ah! That was functionality that was that was moved to the recent file list a few months ago to bring all KDE applications in line with one another.

(Can’t remember when and can’t find it in the changelog in a few minutes, but it was a while ago…

Sorry! :sob:

I haven’t noticed that but that would be a bug and should be filed upstream

:crossed_fingers:

So, there’s no hope that that feature (recovering recent tabs on reopen/restart) would be returned?
(had to look for better document reader)

You can look for an existing bug on the KDE bug tracker and subscribe to it to voice your opinion to the KDE developers or if there is none yet, create one yourself…

:crossed_fingers:

It seems the request is stalled :
https://bugs.kde.org/show_bug.cgi?id=442225

I’ve used 10 of my votes to add to your bug, which is the best I can do at the moment.

:sob:

1 Like

Thanks for that.

1 Like