Official version of wxMaxima will not start

wxMaxima would not start from menus, would just briefly flash.
starting from the command line to see what errors I got, told me that could not be found. Nothing I did could remedy that.
As an alternative, I tried to install the “wxmaxima-git” package available from AUR , but that failed to build.

Having just started wtih Manjaro, after about a ten year hiatus from linux, I defaulted to my old tried and true - but inelegant - solution of “build from source”. Which worked fine for my purposes, but isn’t the most robust solution.

Any hints on what went wrong with the official package, and how I could fix at that level?


wxmaxima from repos installs and runs fine on my end.

  • Is your system up-to-date?
sudo pacman-mirrors -f 5 && sudo pacman -Syyu   
  • Start wxmaxima from terminal and share full output.

output is:
/usr/bin/wxmaxima: error while loading shared libraries: cannot open shared object file: No such file or directory

I’m using the pamac gui, which claims all is up-to-date.

(note I now have a hand built version of wxmaxima in /usr/local/bin that works fine. Would of course prefer to be able to use the official version so that I don’t have to be the one tracking updates etc!)

hmm… I dimly think it may have to do with trying the alternative install from AUR. I think that brought in a different wxgtk library…and that is causing the problem. Would/could that make sense?

I haven’t quite wrapped my brain around arch repositories.

ah…think I got it. i think I had both the above libwx as well as, which I think was pulled in from one of the AUR packages I built.
Anyways when I uninstalled “stuff” installed via AUR packages, and then reinstalled the official wxMaxima file, it works.
(Notice I am a bit “vaguey” on what I did to get this working. I poked some keys, and now it works. No idea what other programs I broke in the meantime, but I’ll burn that bridge when I get to it. )


1 Like

Yes, that was probably the problem. I marked your last post as the solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.