Odroid N2 - new install - no sound

I cant get any audio from the 3.5mm jack. The sound preferences show “Builtin Audio” as detected hardware. The inxi -A output shows

  Device-1: meson-g12a-dw-hdmi driver: meson_dw_hdmi
  Device-2: axg-sound-card driver: axg_sound_card
  API: ALSA v: k6.3.9-1-MANJARO-ARM status: kernel-api
  Server-1: PipeWire v: 0.3.71 status: active

I tried unmuting several controls in alsamixer. Also tried “aplay -D sysdefault:CARD=ODROIDN2 ”, no sound output. The amplifier and speakers are ok, they work when connected to my other PC


1 Like

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

Fixed it !!!

As I am not allowed to post links or screenshots, I am posting the contents of a post originally in Armbian forums.

# Reset and re-initiate ALSA mixer states
rm /var/lib/alsa/asound.state
alsactl init
# Enable 3.5mm output
amixer -c 0 set 'TOACODEC OUT EN' 'on'
# Use I2S B as source for 3.5mm output, I2C A is somehow not usable
amixer -c 0 set 'TOACODEC SRC' 'I2S B'
# Use ALSA device 0 as input for I2S B
amixer -c 0 set 'TDMOUT_B SRC SEL' 'IN 0'
# Enable I2S B (SRC 2) on device 0 (_A)
amixer -c 0 set 'FRDDR_A SRC 2 EN' 'on'
# Set output channels for device 0 (_A)
amixer -c 0 set 'FRDDR_A SINK 1 SEL' 'OUT 0'
amixer -c 0 set 'FRDDR_A SINK 2 SEL' 'OUT 1'
amixer -c 0 set 'FRDDR_A SINK 3 SEL' 'OUT 2'
# Set master volume to 85%
amixer -c 0 set 'ACODEC' '85%'

Got the link with the search phrase “3.5mm Audio Jack not working”

Beware there is a nasty pop when the media starts playback

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.