OBS Screen Capture is showing black screen

I installed obs studio from flatpack using the add/remove software.
I also installed manjajro-pipewire.

Still I am getting a black screen when using obs screen capture or window capture.

Have you tried turning it off and on again?

Like, dude, how do you think ANYONE would be able to help you with that info? “its not working, what is wrong?” LOL

Well generally people ask what they want to know about duh…
How am I supposed to know what is wrong?? I just told you what all I have tried and what the problem I am facing is.

You should ask the information you think might be helpful, not everyone here is a poweruser.

And how are WE to know what is wrong without any information? Magic? Imagination?

That is now how this works. YOU are asking for help. It’s up to YOU to make sure all info needed is provided.
I suggest you read the link I posted and remake your question, be respectful to the ppl you are asking for help from and maybe someone will invest their time in helping you out.

I don’t use OBS nor flatpacks, but have had issues with some applications that want/need to capture/see the screeen/acces clipboard etc on wayland. Some searching mostly helped me with these issues. A likely relevant post on reddit might give some insight:

Providing the inxi info (the link Bedna posted) will show what system you run and will reduce the guessing users have to do about your system to get you up and running.

There is obs-studio in the repo, if there is a reason to use the flatpack version, please clarify or try the repo version and compare results.

Please see: