nVidia xorg.conf not in use

Hi there,

I’m using Manjaro Cinnamon with a GTX1060 card. I have driver version 460.39 in use. I also have GWE installed, and I’m trying to achieve 2 things:

  1. Allow GWE overclock and custom fan curve to work by setting coolbits to 8
  2. Change monitor refresh rate to 75Hz

What I did (as su):

  1. nvidia-xconfig --cool-bits=8
  2. nvidia-settings --assign=CurrentMetaMode="1920x1080_75"

What it achieved:

/etc/X11/xorg.conf was modified, the relevant part:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Coolbits" "8"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "1920x1080_75 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Only problem there is that it doesn’t work. When I set nvidia-settings --assign=CurrentMetaMode="1920x1080_75", my monitor restarts and the OSD says that it’s now running at 75Hz. However, after a reboot it reverts back to 60Hz. Also GWE OC and fan control never works, still asks for the coolbits to be set to 8.

My assumption is that even though xorg.conf is set correctly, it’s not used. What can I do to make this configuration loaded at boot?

Manjaro uses MHWD that is not using xorg.conf.
Use the correct file then, remove yours. To modify with your custom lines, check /etc/X11/mhwd.d/nvidia.conf

To make sure all is fine, run this command after you modify it:
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

2 Likes

Ok, I modified /etc/X11/mhwd.d/nvidia.conf, now it contains the coolbits and 75Hz option. However after running sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf, nothing happens:

[tonyrulez@GTXPC mhwd.d]$ sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf
xorg configuration file: '/etc/X11/mhwd.d/nvidia.conf'

After rebooting, the monitor is still at 60Hz and GWE is still asking for coolbits to set.

Review this line and add the connector to it. For example:
Option "metamodes" "DVI-I-1:1920x1080_75 +0+0"
Needs to correspond the port that monitor is connected …

All Coolbits options should be under Section "Device", NOT Section "Screen" as you have it now … Change that too. To take effect you need to reboot. No need to run that command again.

Okay, according to xrandr the connector is HDMI-0. Changed the line to:

Option         "metamodes" "HDMI-0:1920x1080_75 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"

Moved it to the Device section:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    Option         "Coolbits" "8"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1060 6GB"
	Option "NoLogo" "1"
EndSection

After saving and rebooting, the monitor is still at 60Hz and GWE still asks for coolbits to set :pensive:

You can remove the NoLogo line and maybe you have to use "Coolbits" "12" … Not sure about the refresh rate issue tho. Did you set 75Hz in Monitor Settings of your DE?

You are right, I forgot to set 75Hz in Monitor Settings. After setting it there and rebooting, it stays at that value :heavy_check_mark:

Removed the NoLogo line and changed coolbits to 12. After reboot GWE still not working.

Overclock control requires Coolbits 8 to be set
Fan control requires Coolbits 4 to be set

Interesting. Maybe go with "Coolbits" "28" … but what is funny, on my end i just tested and GWE works and no coolbits in my config, and i get no notification as i should have one or the other.

Unfortunately neither 8, 12 or 28 is good for GWE.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.