NVIDIA X Server Settings has several options missing

I have an HP laptop with NVIDIA GTX 1060 discrete graphics card. I have installed the video-hybrid-intel-nvidia-prime driver. Everything seems to be working fine except NVIDIA X Server setting shows very limited options.

If I run nvidia-settings through the terminal, it returns the following message.

ERROR: nvidia-settings could not find the registry key file or the X server is not accessible. This file should have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see
       the README for possible values and descriptions.

Here is the output of inxi -G

  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
    v: 495.44
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org driver: loaded: modesetting,nvidia
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.2

What am I doing wrong that is causing the options to be missing?

What are you running exactly?
( prime-run nvidia-settings ? Or ? …)


Both nvidia-settings or prime-run nvidia-settings returns the same message and load incomplete nvidia x server settings.

I tried the solution mentioned in the thread you linked. Now, the error message does not show, but the nvidia x server settings is still incomplete.

I also realized there is no xorg.conf inside the /etc/X11 folder and the nvidia.conf file inside the mhwd.d folder is empty.

Is there any way I can generate the xorg.conf file?

Yes … at the same wiki page.

nvidia is … a jerk … so you must use sudo. and then you can also save the file at the pertinent location.
And possibly also run sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

1 Like

Yes … at the same wiki page.

Thanks. I generated the config file as root using

Xorg :1 -configure

and moved to /etc/X11

cp /root/xorg.conf.new /etc/X11/xorg.conf

Now all the options are visible.

Thank you for the help. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.