Nvidia-utils contains nvidia-settings but does not provide or conflict with it

I think there is something not proper yet with NVIDIA drivers. I tried to install nfancurve from the AUR, and it tries to replace the video drivers because it needs nvidia-settings wich is, I think, actually provided within nvidia-utils maybe their is an oversight and nvidia-settings needs to be added to the packages provided by nvidia-utils or maybe there is something wrong on my side and/or I’m confused about the nvidia packages names. From my understanding nvidia-settings provides the Nvidia control panel, that I currently can open from terminal with command nvidia-settings so I assume it is provided with package nvidia-utils already on my machine.

[omano@omano-nvme ~]$ pamac install nfancurve
Warning: nfancurve is only available from AUR
Build nfancurve from AUR ? [y/N] y

Preparing...
Cloning nfancurve build files...
Checking nfancurve dependencies...
Cloning nvidia-utils-beta build files...
Checking nvidia-settings-beta dependencies...
Cloning nvidia-full-vulkan-all build files...
Checking nvidia-settings-full-vulkan-all dependencies...
Cloning nvidia-settings-gtk2 build files...
Checking nvidia-settings-gtk2 dependencies...
Choose a provider for nvidia-settings:
1:  nvidia-settings-beta             455.45.01-1  AUR
2:  nvidia-settings-full-vulkan-all  455.46.02-1  AUR
3:  nvidia-settings-gtk2             455.28-1     AUR

Enter a number (default=1): 

It should install and work properly in theory because I should have nvidia-settings installed already and it shouldn’t try to find an alternative for the missing dependency nvidia-settings.

[omano@omano-nvme ~]$ pacman -Qo /usr/bin/nvidia-settings
/usr/bin/nvidia-settings is owned by nvidia-utils 455.45.01-2

Yes, /usr/bin/nvidia-settings is provided by nvidia-utils.

Edit the PKGBUILD and remove nvidia-settings. You can see a Manjaro user posted about this back in May on the AUR page.

Yes I have done that and I could install the AUR package. But is it a mistake in the AUR package or should nvidia-settings be referenced as provided by nvidia-utils? That is my initial question related to the Testing branch thread because of the new changes with NVIDIA, this is why I didn’t open a new thread initially.

//EDIT: what I meant is that package nvidia-utils provides nvidia-settings but it doesn’t say so in the nvidia-utils package details. In theory nvidia-settings is a standalone package (on Arch for instance, an optional dependency of nvidia-utils), hence why it conflicts with some AUR package on Manjaro, I’m assuming.
Maybe it is intended like that or it is an oversight, but I was wondering why nvidia-settings wasn’t marked as provided by nvidia-utils. Not a big deal but maybe it could create other issues later on.

Good point. I’ll let the boys know.

This post was flagged by the community and is temporarily hidden.

I don’t know why but my previous post has been flagged for being abusive or whatever… no real explanation of why it was removed…

So… any news about this issue? It’s been a month and still the same just wondering what the official response is now.

It was removed for useless bumping. Thank you for actually creating a actual post this time. :wink:

Apparently the issue was overlooked. I’ll take a look when I have some time.

Ah OK… there was not enough words. Not to argue but my second post is basically the exact same thing, with more words. I didn’t feel the need to write an essay to ask the same thing. Whatever.

While I agree with you, we don’t officially support the AUR. There aren’t any packages in our repos that require or conflict with nvidia-settings since it’s part of nvidia-utils. When you come across a package that requires or conflicts with nvidia-settings, edit the PKGBUILD and either replace it with nvidia-utils or remove it.

OK, it was just to make it more in line and “compatible” with the AUR but I agree it is not part of Manjaro.