nVidia target not found error

I’ve tried installing the nvidia driver using the cli commands in the user guide and using the GUI tool but both give me this error. I tried installing the LTS kernel but I wasn’t able to select in GRUB menu it just showed the 5.15 kernel.

This is on a fresh xcfe install. When I mostly found people saying their kernel was too new or out of date. What does that error reference to that there isn’t a target?

OS: Manjaro Linux x86_64 
Kernel: 5.15.12-1-MANJARO 
Uptime: 20 mins 
Packages: 1079 (pacman) 
Shell: bash 5.1.12 
Resolution: 1920x1080 
DE: Xfce 4.16 
WM: Xfwm4 
WM Theme: Matcha-sea 
Theme: Adwaita-dark [GTK2/3] 
Icons: Papirus-Maia [GTK2], Adwaita [GTK3] 
Terminal: xfce4-terminal 
Terminal Font: Monospace 12 
CPU: Intel i7-8700K (12) @ 4.700GHz 
GPU: NVIDIA GeForce GTX 1070 
Memory: 1912MiB / 32037MiB 

Error from GUI attempt but CLI shows same thing.

> Using config 'video-nvidia' for device: 0000:02:00.0 (0300:10de:1b81) Display controller nVidia Corporation GP104 [GeForce GTX 1070]
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: target not found: linux510-nvidia
error: target not found: linux515-nvidia
Error: pacman failed!
Error: script failed!

Done ...

Also possibly related I found that doing the first update after the install the mirror list some how defaulted to using ftp and i eventually found pacman-mirrors -i and that seemed to straighten out some other issues with packages installing older versions and conflicts.

Hello @jajao555,

that seems like you have problems with your package databases. Please try to update these first with the following command:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Then try to install the driver again.

@kisun thanks! That worked.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.