nVidia target not found linux514-nvidia

Hello folks, running sudo mhwd -a pci nonfree 0300 gave me the following output

> Using config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:1f51) Display controller nVidia Corporation TU106BM [GeForce RTX 2060 Mobile]
> Installing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: target not found: linux514-nvidia
Error: pacman failed!
Error: script failed!

inxi -Faxi gives this

  Host: asdru Kernel: 5.16.5-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=b7ccff9c-3ed2-4871-9171-b63a484b3dc9 rw quiet splash apparmor=1
    security=apparmor resume=UUID=796ccbcb-530d-434a-8efd-c4a8a7338c8b
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81UH v: Lenovo Legion Y740-15IRHg
    serial: <superuser required> Chassis: type: 10 v: Lenovo Legion Y740-15IRHg
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: BVCN11WW(V1.07)
    date: 07/04/2019
  ID-1: BAT1 charge: 52.4 Wh (100.0%) condition: 52.4/52.4 Wh (100.0%)
    volts: 13.0 min: 11.6 model: Celxpert L17L3PG1 type: Li-ion serial: 190
    status: Charging
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/4500 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU106BM [GeForce RTX 2060 Mobile] vendor: Lenovo
    driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f51 class-ID: 0300
  Device-2: Chicony Integrated Camera (1280x720@30) type: USB
    driver: uvcvideo bus-ID: 1-7:5 chip-ID: 04f2:b604 class-ID: 0e02
    serial: 0001
  Display: wayland server: X.org compositor: gnome-shell driver:
    loaded: nouveau note: n/a (using device driver) - try sudo/root
    failed: nvidia display-ID: 0 resolution: <missing: xdpyinfo>
  OpenGL: renderer: NV166 v: 4.3 Mesa 21.3.5 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
    class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi
    vendor: Rivet Networks Killer Wireless-AC 1550i Wireless driver: iwlwifi
    v: kernel bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlp0s20f3 state: up mac: 24:ee:9a:ee:76:b8
  IP v4: type: dynamic noprefixroute scope: global
  IP v6: fe80::5692:85f1:6561:5747/64 type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 3f:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp63s0 state: down mac: 7c:8a:e1:20:86:b4
  IF-ID-1: br-1bf583a11769 state: down mac: 02:42:f5:33:99:06
  IP v4: scope: global broadcast:
  IF-ID-2: br-3a91208e20c8 state: down mac: 02:42:b2:23:d1:cd
  IP v4: scope: global broadcast:
  IF-ID-3: br-c504c002828b state: down mac: 02:42:03:a3:0d:27
  IP v4: scope: global broadcast:
  IF-ID-4: docker0 state: down mac: 02:42:54:e6:cd:9b
  IP v4: scope: global broadcast:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 953.87 GiB used: 158.79 GiB (16.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB1T0HALR-000L2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: S3RSNX0M903911
    rev: 5L1QEXA7 temp: 35.9 C scheme: MBR
  ID-1: / raw-size: 919.45 GiB size: 903.95 GiB (98.31%)
    used: 158.79 GiB (17.6%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.41 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 57.0 C pch: 62.0 C mobo: N/A gpu: nouveau
    temp: 48.0 C
  Fan Speeds (RPM): N/A
  Processes: 318 Uptime: 23m wakeups: 1 Memory: 31.27 GiB
  used: 3.27 GiB (10.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1448 pacman: 1434 lib: 357 flatpak: 0
  snap: 14 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.12

From here I tried running sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu and then run again the first command but it didn’t fix the issue

Any clues?

Thanks in advance

you’re running the free nouveau driver and additional wayland. both is not nvidia’s friend.

You still have 5.14 installed which is why the driver installer looks for 5.14 modules.

The solution is to remove linux514

sudo mhwd-kernel -r linux514
1 Like

This worked, thank you so much!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.