Nvidia hardware decoding broken with linux59

I noticed that any branch of the newer nvidia (450xx, 455xx) breaks video hardware decoding on mpv when used with linux59. All the latter work perfectly with linux58. I feel like I should’ve let the community be aware of that in case you were having the same problem as me. Why is that happening? No idea. Have a nice day.

nvidia doesnt work on kernel 5.9
This is well documented on a number of other threads…
nvidia even did a rare announcement themselves:

Which might be good news (because it might mean they ‘fix’ their problems)

… but is also them ‘white-washing’ the real issue:

3 Likes

I also noticed that the actual CUDA version at the driver level was held down. Interesting. Is it a counter measure to deal with nvidia’s bad behavior?