Nvidia GPU does not work, only integrated graphics

I did a switch to linux and it started with problems. All of them are solved except this one. I have dell laptop with integrated graphics and with discreet card. I tried installing optimus manager, but I just crashed the system. What could I do? I have some experience with ubuntu, but I am very new to linux.

I’m quit a novice my self,but followed a few instructions and managed to make it work.
(when i first installed manjaro,i chose boot with propriety drivers which i guess made it easier)

i should mention there has just been a major update that also concerns nvidia drivers support etc.so i have no idea how this affects you and for my part,i guess I’m about to find out .
so check if yours is supported.

this is the official github page:

manjaro wiki page

and some more stuff to read for more details and later configurations:

that’s in-case you installed the OS with Free drivers:



Sorry for late reply. I have successfully installed Optimus manager, but it doesn’t work. I tried to make Nvidia card to be used at boot and that completely broke the system, now only black screen

Please first of all post the output of inxi -Fazy and mhwd -li.

System was unusable, so I booted in single user mode (I believe it’s how it’s called). And now my GTX 1650 works with no issues. Only one issue is that optimus manager doesn’t open so I can’t change back to Intel.

mhwd -li:

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

 video-modesetting            2020.01.13                true            PCI
       video-linux            2018.05.04                true            PCI

video-hybrid-intel-nvidia-prime 2020.11.30 false PCI

Warning: No installed USB configs!

I don’t know how to paste those outputs correctly so I will post outputs this way. And inxi -Fazy did’t let me to paste because I can’t post links.

Use three backticks before and after the text:

some text

is formatted as

some text
1 Like
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=0db97951-df68-43dd-b5c9-cc663a596286 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 snd_hda_intel.dmic_detect=0 single 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: G3 3590 v: N/A serial: <filter> Chassis: 
  type: 10 serial: <filter> 
  Mobo: Dell model: 0VFVNR v: A00 serial: <filter> UEFI: Dell v: 1.11.1 
  date: 08/19/2020 
  ID-1: BAT0 charge: 44.2 Wh condition: 47.3/51.0 Wh (93%) volts: 12.5/11.4 
  model: LGC-LGC4.474 DELL 415CG9A type: Li-ion serial: <filter> 
  status: Charging 
  Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE L2 cache: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 38408 
  Speed: 800 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Dell 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1f91 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:4 chip ID: 0bda:5521 serial: <filter> 
  Display: x11 server: X.org 1.20.10 compositor: gnome-shell 
  driver: modesetting,nvidia resolution: <missing: xdpyinfo> 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus ID: 04:00.0 
  chip ID: 168c:0042 
  IF: wlp4s0 state: up mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-14:5 
  chip ID: 0cf3:e009 
  Local Storage: total: 603.32 GiB used: 16.73 GiB (2.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC501 NVMe 512GB 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: 80002C00 temp: 47.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS541612J9SA00 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B speed: 1.5 Gb/s 
  serial: <filter> rev: C70P 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Force 
  size: 14.59 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.00 
  ID-1: / raw size: 34.35 GiB size: 33.56 GiB (97.70%) used: 16.68 GiB (49.7%) 
  fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 
  ID-2: /boot/efi raw size: 100 MiB size: 96 MiB (96.00%) 
  used: 54.2 MiB (56.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 1020 KiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p5 maj-min: 259:5 
  System Temperatures: cpu: 58.0 C mobo: N/A gpu: nvidia temp: 47 C 
  Fan Speeds (RPM): N/A 
  Processes: 260 Uptime: 8m wakeups: 572 Memory: 7.61 GiB 
  used: 1.84 GiB (24.1%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: 1275 pacman: 1270 lib: 375 flatpak: 0 snap: 5 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.2.01 

Sorry, I am very new to linux and linux forum

Can you please explain the state of affairs now? As far as I see, the NVIDIA GPU is used for rendering, so that’s what you wanted, no?

So now my laptop is working in single user mode and keyboard lags a bit. I use this laptop for gaming and studying, so I need NVIDIA GPU for games, and Intel for longer battery life.

Can you launch anything with the prime-run command? That should force the dedicated gpu to be used.

1 Like

Now it’s running only on dedicated gpu, but I need sometimes integrated too

What do you want to run on dgpu if irs just steam games then right click the game and under launch options type

prime-run %command%

This will force the game to use the dedicated gpu for the game. The laptop will use intergrated gpu by default unless you use prime-run. Another option for gaming is to use lutris where you can set your dgpu to be used. There’s also optimus switch/manager which you can install but prime-run is the preferred option on manjaro

Thank you so much. The only way I found was optimus manager and that didn’t work on my laptop. I was on the way to give up on this and go back to windows.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.