Nvidia Drivers Not Working

First, I’m very new to Linux, specifically Manjaro. I’ve been using Manjaro on my main PC now for about 5 months, so I still have a ton to learn.

GPU - GeForce GTX 1070
CPU - AMD Ryzen 7 2700X

This morning, I updated a bunch of programs through Pamac, restarted the PC, and was met with a black screen. I could access the Terminal through CTRL + Alt + F2, but there was no desktop. Everything was completely fine before I updated. I did some research and came across some instances of people having the same problem, it having to do with the NVIDIA drivers.

I read from some people that uninstalling the drivers and then reinstalling them could help, I tried to uninstall the Nvidia drivers through the terminal but nothing happened.
When I type in the command $ inxi -G, it says that my driver is N/A
I figured that I needed to install the drivers again. I found my way to the Manjaro wiki on how to install Nvidia drivers from the terminal, because beforehand, when I first built this PC, I used the GUI method.
When I type in the command $ sudo mhwd -a pci nonfree 0300, it says "Skipping already installed config ‘video-nvidia’ for device.
Also, I did try $ sudo mhwd -a pci free 0300, the same thing came up

I really don’t know where to go from here. I’ve been using my Manjaro PC for 5 months and have had zero problems up until this point, I really don’t understand what it was in that update that caused this to happen. I know that people say all the time that Nvidia and Linux don’t go well together due to the drivers and the Kernel, but idk, that’s just what people have told me and what I’ve heard from others. Any help at all would be greatly appreciated.

Make sure you are not running an EOL kernel, like 5.9 for example. Switch to another kernel that is LTS or supported.
Also, do not install both free and proprietary drivers.

sudo mhwd-kernel -i linux511

Reboot into the new kernel and only then do remove the EOL kernel:
sudo mhwd-kernel -r linux59

remove the free driver
sudo mhwd -r pci video-linux

force reinstalling the proprietary driver:
sudo mhwd -f -i pci video-nvidia

1 Like

So I successfully installed kernel linux511 like you said, rebooted, then removed the EOL kernel. Also, I successfully removed the free driver, however, when I attempted to force reinstall the proprietary drivers, it gave me an error and said that the script failed. It listed these two lines after it stated that it was checking dependencies.

“error: failed to prepare transaction (could not satisfy dependencies)”
“removing nvidia-utils breaks dependency ‘nvidia-utils’ required by cuda” is what it listed."

Ok, you had some mixed stuff there and probably you had to better run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
sudo pacman -R cuda
sudo mhwd -i pci video-nvidia
sudo pacman -S cuda

This should do it …


It worked! Everything is up and running as usual. Thank you so much for your help, I really really appreciate it. And thank you for responding so quickly!


It didn’t work for me though :frowning:

different problem then

sadly so

Open up a new topic, with the exact errors you get. Chatting here will not help anyone + it can be called tread hijacking

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.