NVIDIA driver couldn't work after driver installation

I wanted to try to get my NVIDIA GPU works (but I prefer integrated graphic for main use) and I installed the driver from Manjaro Settings. After a while I changed my mind, so I closed the NVIDIA installer status (and I thought the download will be canceled, but it continues), and continue do something else. Today, my laptop just stuck in Lenovo logo. I tried opening shell. It worked once. I thought uninstalling NVIDIA stuff would work, so I listed all packages containing word “NVIDIA” and removed them. Then, I rebooted. But it’s still stuck, so I opened shell again but this time, I couldn’t. Everytime I clicked ctrl + alt + f4 it opened the shell for a while but then the display just changed to intense flashing underscore. I tried switching graphics setting on BIOS settings (Switchable to UMA) but it doesn’t work (and I don’t know what UMA is either). I also tried using fallback image but shell won’t open too. Is there any way I could recover my precious OS without reinstalling it? (Plus I just reinstalled Manjaro to SSD yesterday, I don’t want another reinstall). I remember that purging NVIDIA driver worked on Ubuntu when I had similar problem.

Exact steps I did:

1.) I wanted to see if NVIDIA works so I installed it

2.) Closed the status (that shows up when I’m installing) and I thought it was canceled

3.) I did some other stuff. Because I reinstalled Manjaro, I downloaded some softwares.

4.) I shut down the laptop

5.) When I wanted to use the laptop again, the booting stuck on Lenovo logo.

6.) I opened the interactive shell.

7.) Listed all packages with name “NVIDIA” and removed them with pacman.

8.) Rebooted

9.) Booting stuck again, shell won’t open

10.) Switched graphic setting on BIOS to UMA, originally from Switchable

11.) Wrote this question

Informations (note that I couldn’t open the shell either so I couldn’t get LSHW output):

  • Laptop Model: Lenovo G400s
  • CPU: Intel Core i3
  • GPU: Intel HD graphics 4000 and NVIDIA Geforce GT 720m
  • Kernel: Not sure but name of initramfs is “initramfs-5.9-x86_64.img”, and fallback initramfs is 5.9.16-1-MANJARO x64
  • NVIDIA driver: nvidia-390xx
  • Boot mode is UEFI.

Since I couldn’t do anything with current system, I guess best thing to do is to modify a configuration or script, but I don’t know how and which file. So… I want to boot with any graphics card, and then disable NVIDIA or something like that. I just want to boot for now

you have to understand 3 things

  • there is drivers nivdia for PCI Cards and drivers Hybrid with Nvidias for Laptop
  • in all case drivers nvidia need a special compilation with the kernels to works
  • in case of hybrid drivers nvidia , they are working with prime-run / optirun , command for that.

so point

  1. install Nvidia → wrong , there are others drivers
sudo mhwd -l -d 
  1. then you remove drivers Nvidia from kernel , it is not enough
    Xorg conf file have to be changed

for reinstall ( only under TTY or Terminal)

sudo sudo mhwd -a pci nonfree 0300

then after

sudo mhwd -li 

before doing something like that , search in the forum

1 Like