NVidia card + AMD CPU - Cannot boot into live media / installed OS

I recently flashed my motherboard firmware, which for unknown reason, destroyed my ESP partition as well.
As a result, I need to reinstall my Manjaro, with no access to workable OS.
And due to a graphic card issue, I bought a new GFX card as well.

My settings:

Gigabyte X570S Aorus Pro AX
Corsair DDR4 2*8GB
Silicon Power NVMe PCIe Gen3x4 M.2 1TB (ESP partition formatted)
Zotac RTX4060 8GB (new) / Sapphire R290 4GB (old)

BIOS setting: Secure boot OFF, TPM OFF. Fast Boot OFF.

Installer image: Manjaro-KDE-22.1.3-minimal-230529-linux61.iso
Installer tool: Ventoy v1.0.94 (GPT partition)

Using old AMD GFX card

Upon booting using R290, the card doesn’t support UEFI booting, and the MB auto set the CSM in BIOS to OFF mode.
I can boot into live media, and can perform installation of Manjaro normally.

Using new NVidia GFX card

When booting using RTX 4060, the CSM was set to OFF, and Ventoy was launched successfully.
However, when launching the live media, the launching process would stuck forever at this process:

“Starting Create Volatile Files and Directories”

The result is same, whether I select:

  • Normal mode or Grub2 mode
  • Open Source Driver or Proprietary Driver.

When I perform Ctrl+Alt+Del to reboot, this is the screenshot before PC rebooted, which I suppose is irrelevant to my issue…?

I have done some research:


And following the advice in the above 2 posts, I added ibt=off in the boot up command line, then proceed with the launch (tried with Normal mode or Grub2 mode, Open Source Driver or Proprietary Driver), but still same outcome.

Using copy of OS installed during old AMD GFX card

As Manjaro can be installed by using old AMD GFX card, I thought of swapping out the AMD card for NVidia card, after the installation complete.
However, when NVidia card is used, the working copy of Manjaro won’t boot normally - blank screen.
There is signal from the GFX card, but no content to show.


So, as long as the GFX card is NVidia,

  • live media cannot be launched
  • installed Manjaro cannot be launched.

What can I do now?

Other than ibt=off, does anyone have any idea how to troubleshoot?
Or is this a known bug with NVidia cards in Linux environment, which cannot be solved at the moment?
Chipset specific issue? Kernel issue?

Appreciate any help!

That’s impossible, it will only wipe your NVRAM, the two are not the same…

You can not replace a GFX card with one from a different vendor, they are different hardware and thus need different drivers…

An installed system is not meant to be booted using ventoy, ventoy is only usefull to boot the initial setup of any OS, but not to run the installed versions…

If you get blank screen after boot, no matter which GFX card, make sure to turn OFF SecureBoot in the UEFI-BIOS…

What happened is that when you flash your firmware the firmware entry descibing where to locate the grub efi stub - was removed.

Some firmware allows you to create an efi entry manually.

Other wise use the EFI shell to locate the stub and boot the system.

Then you can use grub-install to create a new entry.

The GPU has nothing to do with how you boot your system

Somehow i highly doubt that is an actual photo of YOUR screen, as it has no normal time stamps…

Also instead of describing your hardware please provide FULL output of commands that produce the system info.

Yes we are not here to assist in solving problems from an AI that can’t find the solution on the web…

I have consulted Gigabyte on another issue - the CSM always turned ON with R290 installed.
And Gigabyte response was: R290 doesn’t support UEFI booting, and CSM would always be reverted to ON.
And that’s why I bought a new card RTX 4060 - and when this RTX 4060 is installed, the CSM mode can be turned OFF, which allows installation of W11.
The ESP partition is indeed still there, and when I use detect EFI bootloader to locate, I can find the original Manjaro bootloader, but upon selecting it and launching, it runs into blank screen and rebooted, no error shown.

As per my post, I have never booted into an installed system using Ventoy - Ventoy is solely for booting into live media.
And as per my post, Secure Boot is OFF.
As per your request - please provide FULL output of commands that produce the system info.
how does one provide any output of command, when the system cannot even boot into live media nor OS?

You could try to boot into a text only mode :thinking:
If the LiveMedia doesn’t work using Ventoy, perhaps write the iso to an USB and boot directly from that instead?
(Just eliminate the possible problem caused by Ventoy usage first)

Taht doesn’t make sense.

If your system didn’t support EFI with the previous GPU - wouldn’t you have installed the Manjaro system in BIOS mode?

How CSM (Compatibility Mode) works - at least to my understanding - is that if the system’s boot media is BIOS then bios it is - if the media is EFI then efi it is - which would then cause the Manjaro installation media to boot in BIOS mode because it has been created to support both modes.

The reason you reboot after locating the efi stub manually, could be caused by the efi stub being a leftover from a faiiled installation.

So I suggest you switch on CSM and try booting again using the Nvidia card.

Is your system firmware up-to-date?

If you can boot the ventoy disk - try F4 at the iso select screen … or you can use F2 to locate the efi stub the system disk.

You should also check that the Live media you have downloaded is error free - from your screenshots it appears like something is broken.

When you reach the live media menu - boot with opensource driver - press e to edit the line - insert the a space and the number 3 at the end of the line beginning with linux and press F10 to boot.

You should reach a TTY where you can login using user manjaro, passwd manjaro.

Then you can use sudo manjaro-chroot -a and from there you should be able to install nvidia drivers

sudo mhwd -i pci video-nvidia

If you don’t reach the TTY - then next thing is for you to check that your card get enough juice - you need a 1000w PSU to drive a system with the Nvidia 4xxx card - you likely have 2 8pin power connectors to the card - or something like it.

For comparison PSU wise - my system uses a 7900 XTX in a Lenovo ThinkStation 620 equipped with Threadripper PRO 5945WX and as such comes with a 1000w PSU

@linux-aarhus lets first make sure the OP is actually booting a bare metal version instead of a VM or via Ventoy…
(I don’t know about you, but im personally NOT interested in helping M$ to find ways to make Linux work under their OS to be able to use Wayland…)

As per my 1st post, live media works - as long as it is not NVidia card.
This implies both Ventoy and ISO file are working fine.

And I’m not using VM.

I can’t answer you on this…

Cuz, when R290 is installed, MB will always be in CSM ON mode.
But when installing Manjaro, the installer would show the NVME as GPT, and EFI would be used.

And according to Microsoft, CSM must be OFF to allow W11 installation.
But I have CSM ON, Secure Boot OFF, and yet my W11 installation can proceed flawlessly.

could be caused by the efi stub being a leftover from a faiiled installation.
On this matter, the efi stub is for a working installation of Manjaro.
In fact, I have 2 installations of Manjaro, and both stubs are not working.

So I suggest you switch on CSM and try booting again using the Nvidia card.
CSM will be OFF when booting from Nvidia card.

Is your system firmware up-to-date?
Firmware is F5 - the latest.
And it is the update of this firmware that triggered the whole avalanche.

You should also check that the Live media you have downloaded is error free - from your screenshots it appears like something is broken.
The same live media and Ventoy, are working fine, if R290 card is used.

What exactly is NOT working when using nVidia?
You can not tell us the system is not booting just because you have a different GFX card installed, we won’t buy that nonsense…

What you CAN tell us is that your system boots but has a blank screen etc etc…

Oh sorry, yes sure you can tell us that it cant boot with that nVidia card inserted, but then you have a DEFECTIVE card or MB…

The nvidia card is functioning - there is output when in BIOS setting.

But, when I want to install manjaro, the launching of live media stuck.
This is already described in my 1st post.

You insisted my screen is a fake picture…
You alleged my problem is nonsense…
You accused I use Ventoy to boot into an installed Manjaro…
You want me to provide full command output when i cannot even install Manjaro…
You claimed my live media doesn’t work with ventoy, when i said I can install Manjaro using R290 card…

Pls dun make things complicated.

Please see my edit above

My PSU is 850W.
My setup has no OC.

When using RTX4060 card, I can install W11 flawlessly, using Ventoy.
So do I still need this step?

So to expand to horizon:

R290 installed

  • CSM ON mode + Secure Boot OFF
  • can install Manjaro (EFI).
  • can install W11.

RTX4060 installed

  • CSM OFF mode + Secure Boot OFF.
  • cannot install Manjaro - live media boot up stuck.
  • cannot boot from installed copy of Manjaro - blank screen.
  • can install W11.

When Secure Boot is ON, Ventoy cannot be booted due to key issue.
I tried to enroll the key, but the screen stuck.
Rebooted, retried, still same.
So CSM OFF + Secure Boot OFF, and Ventoy can be launched.

FYI, I have 2 USB drives - both GPT partitions, but one with Secure Boot enabled in Ventoy, and one with Secure Boot disabled.
Both encountered key issues with Secure Boot ON.

Not necessarily - I am throwing in ideas why you get a black screen.

CSM has nothing to do with it. If you can install Win11 which requires secure boot then you may not be able to boot Manjaro due to Secure Boot.

Could you try reaching a TTY using the described edit of the Live ISO kernel line and of course Secure Boot disabled?

Ouch - if you have not already done so - you should use your firmware to load defaults for the firmware.

Sometimes not doing so may leave behind incompatible leftovers in the nvram which needs to be removed by applying defaults.



A default install OR Live media uses real timestamps with date and time…

So yea my “accusations” are mere educated guesses…
:woman_facepalming: :woman_shrugging:

I think the whole FW update did cause a lot of issues.
And it started 1 week ago.
After the FW update, there were multiple issues - OS, GFX card, BIOS settings, blah blah.
Eventually I performed CMOS clearing, which should change all settings to default, but no help.
And that’s why I get a GFX card, cuz it seems like most likely culprit.

The SecureBoot setting needs to be done in your UEFI-BIOS, not ventoy…
For ventoy, or any other bootloader to work in combination with SecureBoot, you need to use a signed SHIM that is accepted by your UEFI-BIOS, only after that you will be able to enroll the key(s)/hashes of the other bootloaders and drivers used by the kernels…

Eg/In other words:
SecureBoot = ON ==> Blank screen using a driver that is not allowed by your UEFI-BIOS…

If you created a backup before flashing you could roll back.

Or fetch an earlier firmware from vendor’s downloadpage.

unfortunately, this board does not have dual BIOS, so cannot switch to backup BIOS when things failed.
The update process was successful - after reboot, the MB boot up with new firmware, and all previous settings reverted to default.
But when I adjusted the BIOS setting and rebooted, the MB entered into loop of endless reboot - just keep rebooting itself - status LED cycled between CPU, DRAM and VGA.
Not entering Boot Device, and no display.
So I have no way to flash any firmware.
Clearing CMOS is the only solution.
But no display still.
Anyway, this is side story - irrelevant to my current NVidia issue.

Please…i beg you when you say stuff, be EXACT of what you did and changed…
With that info ONLY, i would conclude your BIOS-Update just failed and you bricked your MB…

Plus, Please answer a simple question first:
Are you booting on bare metal or from a VM?