NTFS Partition gets damaged

i switched from Manjaro Cinnamon to KDE. I did a fresh installation. With the Cinnamon Edition it was no Problem to use my NTFS USB Stick (need NTFS for my TV). But with KDE everytime i safely remove the Stick the NTFS File System gets corrupt. Then i need to fix it with Windows (NTFSFIX wont fix it) and some Files are broken. Sometimes new ones i copied fresh and sometimes old data. Doesnt matter if i wait before safe remove or remove it directly. With Cinnamon everything was fine. Do u have any ideas what it can be?

Hello @odin89 :wink:

Not sure, but how does Dolphin mount the usb flash drive?

Mount the flash drive normally and type this into the terminal

mount | grep -i "/dev/sd[a-z]"

and post the out put here as code.

It could be possible that it does not sync it… Please try this:

  1. Mount as usual
  2. Copy files.
  3. Run sync on the terminal
  4. Now safe remove it

Problem occurs again?

You should wait until you see a message pop telling it is safe to remove the device.

First of all thanks for u answers. The stick gets mount with this

/dev/sdh1 on /run/media/odin/tv type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

i tried it now and when i go to a terminal after copy the files and use “sync” then it works. I can put it in back and everything is fine. Thanks for that hint :slight_smile:

But why is it a problem wit Manjaro KDE (tried it with dolphin and Thunar) and with Manjaro Cinnamon everything worked like a charm?

edit: Everytime i waited that i can remove the stick. but it was corrupted at all

  1. sync (optional)
  2. umount (normally includes sync)
  3. wait until all data is written (this can take minutes !)
  4. unplug

This is even advisable, when the filesystem is resilent (self-repairing). Because otherwise the last files may be missing on the stick. :sob:

This may be an open ended response, but how long would one have to wait for this message to be presented?

Even with a exFAT or FAT32 formatted USB device, I (and many others) experience such an issue as we seem to be pulling out our USB’s before this sync has been completed.

Does the RAM size or Disk size affect this wait duration?

There is various system parameters which influence the time taken to flush the queue to the device.

If in doubt issue a sync command in the terminal - when the prompt returns - it is safe to remove the device.

A couple of threads on the subject - there is more to find if you search for it

1 Like