A permanent solution to dirty bytes anywhere on the horizon?

When I started using linux dirty bytes was a problem when copying files to a usb drive and it still is unless the dirty bytes are adjusted. I don’t believe that Windows had this problem. Are there any fixes that can be set as default and would work for any hardware? Why isn’t this a problem in Windows?

What do you call “dirty bytes”? I’m not familiar with that…


A few discussions about the topic


I personally never had such issue on Linux ever …


I never have had dirty memory. Once in a year i do clean my pc with the vacuum cleaner. But it’s really amazing how quickly the pc picks up dust.

But when i rethink this, i do have dirty bad memories of windofs98


For me the dirty bytes has always been a problem. Plasma reports that the transfer has completed, but in reality when I pull out the USB thumb drive the data is only partially copied. Having a drive with a LED helps a lot.

You do know that you need to unmount the drive before unplugging it, do you?


To further @freggel.doe’s post, just because Plasma (or whichever desktop) claims the transfer is complete, you still need to “safely remove” / unmount the device before physically removing it.

You’ll likely observe a noticeable delay after clicking Safely Remove for sticks with slow write speeds.

Fair point. I’m just not sure how many people actually unmount before unplugging since this isn’t an issue on Windows, because it correctly reported the transfer status.

I’ll make sure to unmount drives from now on. Although this might be an unexpected and unpleasant surprise for new users that are use to just unplugging.

Is there really no other way for plasma to correctly verify when a transfer has completed? I have searched for solutions, but couldn’t find any.

If write caching is enabled, they always should “safely remove” an external USB drive. Even with write caching disabled, it’s good practice to always do this, since it will check if any files are currently using the drive. The same principle holds true for Linux, regardless of desktop environment.

Even people I knew who were not very computer savvy made “ejecting it from the tray icon” a routine thing before physically unplugging the USB drive. These are Windows users.

Disable write caching on the device in question perhaps? Not sure, as I haven’t tried it out recently. :man_shrugging:

It’s a bit out of scope at this point, and there’s other alternatives such as the “sync” and “flush” mount options, and outright disabling write cache for the device itself. Never tried it recently, and I’m not sure what types of performance penalty you might get.

You should also do that on Windows, with the “safely remove USB device” thing made specifically for it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.