Notifications doesn't work after update

Hi, I’m on bspwm and after recent update I get an error when I run notify-send:

Could not connect: No such file or directory

It seams that issue is related with dunst deamon, but I don’t have knowledge about notifications in Linux. Dunst server is dead.

❯ systemctl status --user dunst
 Active: inactive (dead)

When I try to run dunst I have msg:

CRITICAL: [dbus_cb_name_lost:1050] Cannot connect to DBus.

“dunstctl debug” isn’t helpful.

And easy workaround woild be to remove dunst and install an alternative Desktop notifications - ArchWiki

xfce4-notifyd would be suitable

Isn’t it that notify-send should work only with libnotify?

I’ve tried Deadd Notification Center deamon and I have the same issue, but I got more verbose message:

deadd-notification-center: SocketError {socketErrorMessage = "Network.Socket.connect: <socket: 75>: does not exist (No such file or directory)", socketErrorFatal = True, socketErrorAddress = Just (Address "unix:guid=3cd6f9527aab571200ce7ccf63d265b1,path=/tmp/dbus-PkmgVzZLwE")}

The problem is that I don’t have that /tmp/dbus-PkmgVzZLwE file. Dbus doesn’t create it even I have:

echo $DBUS_SESSION_BUS_ADDRESS
unix:path=/tmp/dbus-PkmgVzZLwE,guid=3cd6f9527aab571200ce7ccf63d265b1

I don’t see any errors in journalctl related to dbus.

Are you by any chance using dbus-x11 package instead of dbus ?

1 Like

No, it’s quite opposite. Once again I’ve checked pacman.log and in the last manjaro update, dbus-x11 was replaced by dbus.

[2023-01-24T15:05:08+0100] [ALPM] removed dbus-x11 (1.15.0-2)
[2023-01-24T15:05:10+0100] [ALPM] installed dbus (1.14.4-1)
[2023-01-24T15:24:31+0100] [ALPM] running 'dbus-reload.hook'...

Should I come back to dbus-x11?

I’ve read that this issue could be related to lightdm. It can be a true cos in my laptop with ly I don’t have this problem.

I found solution, but I maybe it’s more like workaround. In my autostart file I create new socket:

export $(dbus-launch)

Pointing DBUS_SESSION_BUS_ADDRESS env to /run/user/1000/dbus/user_bus_socket didn’t work for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.