Dbus-x11 deprecated?

Hi all,

dbus-x11 is an AUR package, and it’s “explicitly installed” by me. However, I forgot why, and I believe it used to be a package from the official repositories.

My question is; has it been deprecated? And can I safely delete it?

1 Like

You can likely install dbus which will ask if you want to replace dbus-x11 with it and you just say yes to that.

didnt work, could not install dbus:

conflicting dependencies:

  • dbus-nosystemd and dbus-x11 are in conflict

Why do you have dbus-nosystemd installed or try to install it?

It’s an AUR package, that has not been updated in almost 2 years.

i dont have dbus-nosystemd installed, i have dbus-x11 installed and when i try to install dbus, that is the error message i get.

Try with sudo pacman -S dbus.

Post all output if it complains.


Does not compute. Why would you see that message if you didn’t?

Full logs, please. See [HowTo] Request support

FYI, dbus-nosystemd is only in the AUR for folks that think they can use Arch (or Arch-based distros like Manjaro) without systemd. There are other distros that don’t use systemd they should probably use instead.

Install dbus with the following command and answer y for all conflicts:

sudo pacman -Syu dbus
1 Like

it worked with this command, no problems. prior to install, it asked to remove dbus-x11, and I did.

Same problem here! dbus-nosystemd is not installed but get error message if I want to update my system.

Error Msg: “In Konflikt stehende Abhängigkeiten: - dbus-nosystemd und dbus-x11 stehen im Konflikt zueinander”

After that I can edit the buildfiles for openssl-1.0 and dbus-x11.
Why openssl-1.0 it’s rather old. (but installed, dont know why, will remove it cause openssl-1.1 is installed)

pamac search dbus-nosystemd

lib32-dbus-nosystemd-git 1.12.20-1 AUR
dbus-nosystemd-minimal-git 1.12.20-1 AUR
dbus-nosystemd 1.12.20-1 AUR

pamac search dbus-x11

dbus-elogind 1.10.18-1 AUR
dbus-x11-docs 1.15.0-2 AUR
dbus-x11 [Installiert] 1.14.4-1 AUR


Arch dropped it from the repos to the AUR just recently.

Worked for me. Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.