Not able to download Nvidia drivers

i was trying to download the nvidia drivers but unsuccessfull… doesn’t anyone know how to fix this? im running manjaro XFCE

Can you try to execute the following command on console:
pacman -Syyu


can you return

inxi -Fza
sudo mhwd -li

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for ninoysg:
:: Synchronizing package databases…
core 169.2 KiB 1459 KiB/s 00:00 [######################] 100%
extra 2013.0 KiB 2.20 MiB/s 00:01 [######################] 100%
community 6.2 MiB 4.21 MiB/s 00:01 [######################] 100%
multilib 194.3 KiB 7.03 MiB/s 00:00 [######################] 100%
:: Starting full system upgrade…
there is nothing to do

inxi -Fza
  Kernel: 5.6.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=b475c05f-c2d9-4383-a3a5-8499f27bca89 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire F5-573G v: V1.04 
  serial: <filter> 
  Mobo: Acer model: Captain_SK v: V1.04 serial: <filter> UEFI: Insyde 
  v: 1.04 date: 04/26/2016 
  ID-1: BAT1 charge: 48.5 Wh condition: 48.5/61.0 Wh (79%) volts: 12.5/10.9 
  model: LGC AS16B8J type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: D6 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 20810 
  Speed: 491 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 496 
  3: 498 4: 496 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Skylake GT2 [HD Graphics 520] 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:1916 
  Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Acer Incorporated ALI 
  driver: nouveau v: kernel bus ID: 01:00.0 chip ID: 10de:139a 
  Device-3: Realtek HD WebCam type: USB driver: uvcvideo bus ID: 1-7:6 
  chip ID: 0bda:57f2 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 driver: intel,nouveau 
  unloaded: modesetting alternate: fbdev,nv,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  Monitor-2: HDMI1 res: 1920x1080 hz: 60 dpi: 111 
  size: 440x240mm (17.3x9.4") diag: 501mm (19.7") 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d70 
  Sound Server: ALSA v: k5.6.15-1-MANJARO 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0 
  chip ID: 168c:0042 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus ID: 04:00.1 chip ID: 10ec:8168 
  IF: enp4s0f1 state: down mac: <filter> 
  Device-3: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB 
  driver: btusb bus ID: 1-5:4 chip ID: 04ca:3015 
  Local Storage: total: 3.17 TiB used: 7.63 GiB (0.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: SanDisk model: Ultra II 480GB size: 447.13 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 20RL scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST2000LM003 HN-M201RAD 
  size: 1.82 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-3: /dev/sdc type: USB vendor: Toshiba model: MQ01ABD100 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B 
  rotation: 5400 rpm serial: <filter> scheme: MBR 
  ID-1: / raw size: 156.74 GiB size: 153.28 GiB (97.79%) 
  used: 7.60 GiB (5.0%) fs: ext4 dev: /dev/sda5 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 43.5 C mobo: N/A gpu: nouveau temp: 42 C 
  Fan Speeds (RPM): N/A 
  Processes: 201 Uptime: 13m Memory: 7.65 GiB used: 1.84 GiB (24.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1082 
  lib: 313 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05 
sudo mhwd -li

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Hmmm seems like there is likely a blocking package here. You would need to remove that one first.

You can easily find out the names of the packages by trying to install via console.
I am guessing you were trying to install the 450xx prime driver, so this would be the command for that:
mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

If you are still unsure after reading the tutorial, please post the output you get back from the command.

thanks for that!! the problem is i really dont know whats blocking it and how to do it and install the driver… im really a linux noob…

Let me reiterate:
sudo mhwd -i pci video-hybrid-intel-nvidia-450xx-prime

Already tried that and this is what it said:

Installing video-hybrid-intel-nvidia-450xx-prime…
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-450xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases…
warning: nvidia-450xx-utils-450.66-1 is up to date – skipping
error: target not found: linux56-nvidia-450xx
core is up to date
extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!
Error: script failed!

You must install a recent kernel, before you can install the graphics driver.

1 Like

I’m running into the same issue with a fresh install (downloaded iso two days ago). It worked originally but stopped working when I reinstalled the system due to some other problems.

It appears the repositories for it are down or something:

sudo pacman -Syu nvidia
[sudo] password for charlesrwest:
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: There are 13 providers available for nvidia:
:: Repository community

  1. linux54-rt-nvidia-340xx 2) linux54-rt-nvidia-390xx 3) linux54-rt-nvidia-418xx 4) linux54-rt-nvidia-430xx 5) linux54-rt-nvidia-435xx
  2. linux54-rt-nvidia-440xx 7) linux54-rt-nvidia-450xx 8) linux56-rt-nvidia-340xx 9) linux56-rt-nvidia-390xx 10) linux56-rt-nvidia-418xx
  3. linux56-rt-nvidia-430xx 12) linux56-rt-nvidia-435xx 13) linux56-rt-nvidia-450xx

Enter a number (default=1):

It’s just showing the rt versions.

Then you should install kernel 5.6.19 rt.

And try again.

Doesn’t rt stand for real time? Aren’t there performance issues associated with using real time kernels when you don’t need them? Also, it really seems like some sort of repo bug, given that the fresh install is still recommending packages that don’t exist after updating.

Why not switch to a newer kernel then, as 5.6 is EOL. 5.8 is still gonna have support for some time.

already switched to the newest kernel 5.8 but still having the same problem

Is there some way to check if the repos are up still?

found the solution…try to change the kernel specifically to 5.7 and then try to install the nvidia driver 450xx… it worked for me

That didn’t work for me.

However, getting today’s live disk did.

i have the exact same problem. fresh install, everything up to date, script via manjaro settings > hardware > graphics driver doesnt work. same output as above. repo not working? that should be easy to fix. wrong kernel? dont want to ■■■■ up my install with strange operations so please enlighten me. thanks! just wait maybe?

here is the output, im trying to instal nvidia 450:

extra is up to date

community is up to date

multilib is up to date

Error: pacman failed!

Error: script failed!

and how did you fix it with the live disk? disk? i mean i dont even own a cd player any more.