Nordlayer not working

I am trying to setup the VPN software Nordlayer and It wont work. Ive tried every different VPN service (NordLynx, IKEv2, OpenVPN) and none work. I have no other VPNs and I tried resetting my internet connection settings, but nothing seems to work. What can I do to fix this?

1 Like

What kind of info should I put? All I have are error messages when trying to connect.

What exactly have you tried?
What tutorial(s) did you follow?
What package(s) did you install?

I can only speak to the cli tool (using networkmanager+openvpn) working in the past.
(nordnm in the AUR)

I’ve tried reinstalling, changing VPN type, and rebooting
I didn’t see any tutorials
I installed nordlayer from the aur.
It is a different command line tool than nordnm so I’m not really sure what to do

So … you didnt do anything else except install the package?

Because I notice that their documentation states you need to add your user to the nordlayer group.

I also notice the PKGBUILD delivers a service file … but I have no idea whether it should be manually enabled or not … it does not seem to be mentioned in the documentation.

Anyhoo … from there … I suppose you are using it as outlined here:

So first things first - add yourself to the nordlayer group:

sudo usermod -a -G nordlayer $(whoami)

Then try again:

nordlayer login

I have the service active, and have run the usermod command several times, but it seems to do nothing.

Is your user part of the group?



sys network power nordlayer lp wheel autologin derp

Beyond that, and just making sure you are up to date:

sudo pacman -Syu

(if you have updated then rebuild the nordlayer package)
… I cant help much more.
Its proprietary software.
You should contact them for support.
(though I understand they only support Debian/RHEL, so might flatly tell you as much)

Don’t worry about it. I can’t seem to get to work but I do have a small windows install on my pc so I can just use that since I assume it would work on there.

Those error messages are important. They will tell you — or us — why it doesn’t work.

Nordlayer is a commercial service.

Without any means of replicating due to non existing free accounts - it is impossible to advise or attempt to provide any suggestions as what is required.

The best advise is to use a supported OS → Operating systems | Nordlayer Help