[noob] I am not sure to use my GPU


I’ve newly tried to install manjaro xfce 20.1.2
Installing stopped after failing starting Light Display Manager. I’ve found some explanations about nvidia driver. But I haven’t nvdia.
Then I started a new installation with architect and succeeded after installing video-vesa driver.

I believe that I’m not using my GPU… That’s why I’m asking you how to verify it. How can I find the name of my GPU, know if it’s used and know which driver I need for ?

Many thanks.


Alot of ground to cover here … but you almost certainly shouldnt be using vesa.

Configure Graphics Cards - Manjaro

How to provide good information

Sorry for not providing my system information first.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=b1311b37-fe24-446f-bfad-741ffa21c0cb rw quiet udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Packard Bell BV product: EasyNote_MX37-U-056FR 
  v: PC10E06402 serial: <filter> Chassis: PACKARD BELL BV type: 10 
  serial: <filter> 
  Mobo: PACKARD BELL BV model: T12C v: 1.0 serial: <filter> 
  BIOS: American Megatrends v: 218 date: 04/25/2008 
  ID-1: BAT0 charge: 17.8 Wh condition: 18.0/47.3 Wh (38%) volts: 12.3/11.1 
  model: PACKARD BELL T12--22 type: Li-ion serial: N/A status: Unknown 
  Info: Dual Core model: Intel Pentium Dual T2370 bits: 64 type: MCP 
  arch: Core Merom family: 6 model-id: F (15) stepping: D (13) microcode: A4 
  L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 6934 
  Speed: 1733 MHz min/max: 800/1733 MHz Core speeds (MHz): 1: 1733 2: 1733 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter 
  vendor: Packard Bell B.V. driver: N/A bus ID: 01:00.0 chip ID: 1039:6351 
  Display: x11 server: X.Org 1.20.9 driver: vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 271x203mm (10.7x8.0") 
  s-diag: 339mm (13.3") 
  Monitor-1: default res: 1024x768 
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 128 bits) v: 4.5 Mesa 20.2.3 
  compat-v: 3.1 direct render: Yes 
  Device-1: Silicon Integrated Systems [SiS] Azalia Audio 
  vendor: Packard Bell B.V. driver: snd_hda_intel v: kernel bus ID: 00:0f.0 
  chip ID: 1039:7502 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter 
  vendor: Packard Bell B.V. driver: sis190 v: 1.4 port: cc00 bus ID: 00:04.0 
  chip ID: 1039:0191 
  IF: enp0s4 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter 
  vendor: AzureWave AW-GE780 802.11bg driver: ath5k v: kernel port: dc00 
  bus ID: 02:00.0 chip ID: 168c:001c 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 232.89 GiB used: 7.99 GiB (3.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST9250827AS size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: <unknown> 
  rotation: 5400 rpm serial: <filter> rev: A scheme: MBR 
  ID-1: / raw size: 229.88 GiB size: 225.28 GiB (97.99%) used: 7.99 GiB (3.5%) 
  fs: ext4 dev: /dev/sda2 
  Kernel: swappiness: 10 (default 60) cache pressure: 50 (default 100) 
  ID-1: swap-1 type: partition size: 3.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda1 
  System Temperatures: cpu: 59.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 152 Uptime: 3m Memory: 2.80 GiB used: 547.1 MiB (19.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1079 lib: 311 
  flatpak: 0 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.08

~ >>> mhwd -l --pci

0000:01:00.0 (0300:1039:6351) Display controller Silicon Integrated Systems Corp.:
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

When I tried to boot with video-modesetting manjaro didn’t even start.

Thats pretty old.
What is your GPU exactly? It doesnt seem to be recognized as an intel or radeon or …

(PS - given the age … I suggest going with a slightly older LTS driver like maybe 5.4 or 4.19)

This hardware is a bit dated and you probably need to install the driver manually. I saw an AUR package for it but there are reports of it being broken in 2018 and no update since. So I would not recommend it.

aur/xf86-video-sisimedia 0.9.1-13 (+3 0.00) (Out-of-date: 2018-07-15) 
    X.org SiS 671 video driver

I also found this page but it is ugly and you should try it only if you are desperate and if you have taken a snapshot of your system before (with e.g. Timeshift). if it works, it is not integrated in the package management system and may break (if it ever works in the first place).

Using an other hard disk I’ve installed Ubuntu LTS 20.04 with a 5.4 kernel on the same computer. The driver used is xf86-video-fbdev, it works fine.
I downloaded it with pacman on manjaro and I configured it on Xorg.

sudo Xorg :2 -configure
sudo mv /root/xorg.conf.new /etc/X11/xorg.conf.d

but I’m still not able to use the new driver by using

mhwd -i pci video-fbdev
Error: config 'video-fbdev' does not exist!

did I forget something ?

I will try a 5.4 kernel soon.

Hardware info :

Packard Bell MX37-U-044
Processeur Pentium Dual Core T2370 (1.73 GHz), 2 Go DDR2 667 MHz, un disque dur SATA de 250 Go à 5400 trs/min, un chipset graphique intégré SIS M672 256 Mo

What do mhwd -l and mhwd -li say?

mhwd -l
0000:01:00.0 (0300:1039:6351) Display controller Silicon Integrated Systems Corp.:
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

mhwd -li
Warning: no installed PCI configs!
Warning: no installed USB configs!

Same troubles on kernel 5.4

I think you have to install extra/xf86-video-fbdev before trying mhwd -i pci video-fbdev.

mhwd -l shows that it is not available to install.

I give up, Kali Linux and Ubuntu works fine. Thank you for your support !

I will try manjaro again with a new computer.