Noise starting sound on AMD Ellesmere HDMI Audio Radeon RX 590

When I play sound it starts with a noise in the first second before becoming normal. It seems to be when the sound system is initialized after a pause, as it only happens after the system has been silent for a while. The noise comes when I run on kernel 5.18.12-3, but not on kernel 5.15.55-1. It did not happen on kernel 5.18.7-1 or earlier.

Gigabyte Radeon RX 590 Gaming 8GB rev. 1.0

export LANG=C && inxi --admin --verbosity=7 --filter --width

  Kernel: 5.15.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=bbaf3e0f-20db-40ad-b4ad-720e50db787a ro nosplash noresume
    nohibernate udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450-PLUS v: Rev X.0x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 2008
    date: 12/06/2019
  Device-1: hidpp_battery_0 model: Logitech M215 serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
  RAM: total: 15.56 GiB used: 1.94 GiB (12.5%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x71 (113)
    stepping: 0 microcode: 0x8701013
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2333 high: 3592 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2944 2: 2053
    3: 2143 4: 2191 5: 2196 6: 2194 7: 3592 8: 2052 9: 2053 10: 2192 11: 2195
    12: 2192 bogomips: 86273
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse
    sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
    topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Gigabyte driver: amdgpu v: kernel arch: GCN 4 process: GF 14nm
    built: 2016-20 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-3,HDMI-A-1 empty: DP-1,DP-2,DVI-D-1
    bus-ID: 08:00.0 chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x2160 s-dpi: 96 s-size: 1182x570mm (46.54x22.44")
    s-diag: 1312mm (51.66")
  Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,top-left
    model: Philips FTV serial: <filter> built: 2017 res: 3840x2160 hz: 60
    dpi: 68 gamma: 1.2 size: 1440x810mm (56.69x31.89") diag: 1652mm (65")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: bottom-r model: Denon DENON-AVR
    serial: <filter> built: 2014 res: 640x480 hz: 60 dpi: 23 gamma: 1.2
    size: 708x398mm (27.87x15.67") diag: 918mm (36.1") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon RX 590 Series (polaris10 LLVM 14.0.6 DRM 3.42
    v: 4.6 Mesa 22.1.3 direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 08:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.55-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.55 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.52 TiB used: 1.48 TiB (58.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EADS-00L5B1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: 1A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EADS-00L5B1 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 1A01
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Micron model: MTFDDAK256MAY-1AH12ABHA
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: M5T4 scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: A-Data model: SU800NS38
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 8B scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 468.13 GiB size: 459.72 GiB (98.20%) used: 25.6 GiB (5.6%)
    fs: ext4 dev: /dev/sdd1 maj-min: 8:49 label: e2root
    uuid: bbaf3e0f-20db-40ad-b4ad-720e50db787a
  ID-2: /home/adisk raw-size: 931.51 GiB size: 915.82 GiB (98.31%)
    used: 768.06 GiB (83.9%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: adisk
    uuid: a0f67169-c4c3-48e9-bafe-a73dc0983560
  ID-3: /home/bdisk raw-size: 931.51 GiB size: 915.82 GiB (98.31%)
    used: 692.07 GiB (75.6%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: bdisk
    uuid: ed96f3d3-edea-43bc-8418-2223e4ec312d
  ID-4: /home/cdisk raw-size: 238.47 GiB size: 233.67 GiB (97.99%)
    used: 30.89 GiB (13.2%) fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: cdisk
    uuid: f94e8a24-3ec4-4edb-b49f-0d26ab9fef52
  ID-5: /home/<filter>/cryptomount.fredox.vol raw-size: 600 MiB
    size: 573.7 MiB (95.62%) used: 455.3 MiB (79.4%) fs: ext4 dev: /dev/dm-1
    maj-min: 254:1 mapped: loop0 label: N/A uuid: N/A
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-0 maj-min: 254:0 mapped: swap label: swap
    uuid: 59bb8af1-1a61-48d6-9652-b9582aa07104
  ID-1: /dev/sdd2 maj-min: 8:50 size: 8.8 GiB fs: ext2 label: cryptswap
    uuid: a6fb126a-9bf7-40ed-84c2-2fbf22d608d3
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-4:3 info: Jing-Mold Enterprise 2.4G Dongle
    type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 05af:0906 class-ID: 0301
  Device-2: 1-7:4 info: Logitech Unifying Receiver type: Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52f class-ID: 0300
  Device-3: 1-9:5 info: NZXT Smart Device V2 type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 1e71:2006 class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-2:2 info: Genesys Logic USB3.0 Hub ports: 4 rev: 3.0
    speed: 5 Gb/s chip-ID: 05e3:0617 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 63.0 C mobo: 34.0 C gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): cpu: 1333 fan-2: 0 fan-3: 0 fan-4: 0 fan-6: 0
    gpu: amdgpu fan: 781
  Power: 12v: N/A 5v: N/A 3.3v: 3.29 vbat: 3.23 gpu: amdgpu watts: 28.12
  Processes: 319 Uptime: 21m wakeups: 9 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
  Packages: pacman: 1166 lib: 261 Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.19

The BIOS has a 2022 update PRIME B450-PLUS|Motherboards|ASUS Global

That one is fine, but maybe for your case the 5.18 will provide more features …

Have you also tried using Pipewire, does the noise only happens over HDMI to Monitor Speakers or is some other audio speaker/headphone? Have you tried in alsamixer to alter some values?

Thank you bogdancovaciu, I updated the motherboard BIOS.

The BIOS update had no influence on the noise, the phenomenon is completely reproducible on kernel 5.18.12-3, but not on kernel 5.15.55-1. It did not happen on kernel 5.18.7-1 or earlier.

I will wait and see if the next kernel-update will make any difference.

check the power-settings

Thank you Olli for the suggestion, but it did not work for me.

I restarted the PC on kernel 5.18.12-3 , switched to tty 2 and ran

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
echo N | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller

then switched to the login screen and logged in to the desktop. The startup sound was sort of OK, but to make sure I waited 5 minutes and then played a sound.

The noise came again.

I checked with

$ cat /sys/module/snd_hda_intel/parameters/power_save

$ cat /sys/module/snd_hda_intel/parameters/power_save_controller 

The parameters were still there.

Have you tried using Pipewire yet @fredvej ?

PulseAudio has a module to suspend audio sinks (outputs) after a few seconds when devices are idle

Try removing the module temporarily first:

pacmd unload-module module-suspend-on-idle

If that works to eliminate the noise use this command to comment out the module load command in PulseAudio configuration:

sudo sed -i '/load-module module-suspend-on-idle/s/^/#/' /etc/pulse/

Hi, I am on Gentoo 5.18.12 and have the same problem with my RX570. In 5.18.0 everything was still fine. I first detected it in 5.18.9 (didn’t install all minor versions in between).
It must be a kernel problem, the rest of the software stack is the same. Switching the kernel back to 5.18.0 resolves the problem immediately.
I have no pipewire, I only use pulse audio

Manjaro kernel probably does not have the same configuration as you have compiled for Gentoo kernel
Manjaro KDE requires both PulseAudio and PipeWire as dependencies
And OP already has an earlier kernel (latest LTS v5.15) working without noise problems


The bug was definitely introduced with 5.18.8. I tried to diff the kernel sources, but didn’t find the culprit

I just upgraded to kernel 5.18.14 , and the noise is still present.

Solution: in /etc/pulse/ add


to entry

load-module module-udev-detect

resulting in

load-module module-udev-detect tsched=0

Reboot and be happy

Edit: It was good for one day, now the problem reoccured. So this is not the total fix

Turning off timer-based scheduling in PulseAudio is only suitable for older audio devices
and not likely to help with ALC887-VD2 audio codec on OP system

Even if disabling timer-based scheduling is appropriate for an audio device, PulseAudio may also need changes to configuration for default-fragments and default-fragment-size-msec
4.3 Setting the default fragment number and buffer size in PulseAudio

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.