No write permission for my non boot drive

Hi there,

As you can tell from my login I’m new to all this. So far everything was going great but recently something changed for no reason. The way I run my Linux is from an external SSD which I connect via USB to my laptop. This way I have also access to my internal HDD drive. UP until now I could read and write to both drives but today I noticed that I can only read the contents of the internal drive but can’t copy or write to it. Initially, I thought it was the issue of dolphin but it worked fine with my SSD drive so I’m a bit lost here and would be gratefull for some help.

Welcome to the forum!

First of all, if your internal drive is NTFS, then you must disable fast boot and hybrid sleep in Windows, because that leaves your NTFS volumes in an open state, and the Linux kernel will then regard those filesystems as damaged, and will then mount them read-only so as to prevent further damage.

If the above is not applicable, then please read the following tutorials. :arrow_down:

1 Like

Thanks a lot for a quick response, I’ll get to reading now.


I disabled the fast boot and hybrid sleep and it seems to have fixed the issue. Thanks a lot!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.