No WiFi on Manjaro with D-Link DWA182 USB Adapter

Hello everyone,


pamac build rtl88x2bu-dkms-git

I’m having trouble connecting to WiFi on my Manjaro Linux system with a D-Link DWA182 wireless USB adapter. I’ve tried several solutions but nothing seems to work. Here’s what I’ve tried so far:

  • Checked if the Network Manager is running. It wasn’t initially, but now it is.
  • Enabled WiFi using the command nmcli r wifi on. The output shows that WiFi is enabled.
  • Tried to list available WiFi networks using the command nmcli d wifi list, but it doesn’t show any networks.
  • Unplugged the D-Link DWA182 wireless USB adapter and plugged it back in.
  • Restarted the router.

Despite these efforts, I’m still unable to connect to WiFi. Currently, I’m using my phone’s mobile data to provide internet to my computer, but I’d like to connect to WiFi instead. Any suggestions on how to fix this issue?

Thank you in advance for your help.

You might want to edit your title.
At first glance it appears you already have a solution.

Also please see this


First you have to prepare your system to deal properly with AUR. From terminal run:
sudo pacman -Syu base-devel --needed

Then you install the linux headers for your installed kernels. This command will install automatically (in case you have more than one kernel installed):

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then you build the package:
pamac build rtl88x2bu-dkms-git