No Wifi on Manjaro on Lenovo Yoga 6

I installed Manjaro KDE on a Lenovo Yoga 6. Everything so far appears to be running smoothly except that I have no Wifi. Cabled connection works fine, but when I open the networks it says no connections available even though I know there are wifi connections.

I’ve tried this also with Cinnamon, Gnome and the issue is the same.

Any ideas?



Laptop is a Lenovo Yoga 6 13 2-in-1 13.3" Touch Screen Laptop with AMD Ryzen 7.

Please provide some information about your system. Please read the following and post inxi output as specified. This will help us here to help you:

I had something similar this week, just got a Lenovo thinkpad L14. Problem is that they ship with a wifi card that needs a proprietary realtek driver, intel wifi card should be ok. Hopefully you are not in the same boat. I will send mine back.

This package contains the correct firmware in the AUR: rtw89-dkms-git

I had the same problem. It is just very new.


Just joined and already provided a solution. Amazing! Welcome!

To be more precise, could you please post you inxi output for the wifi network adapter you have? That can be helpful to further users search as another one keyword to match.

It should be somewhere around

$ inxi -Nazy1

Thanks and welcome to the Welcome and introduce yourself - 2021 :slight_smile:

I was faced with the same no wifi problem with a new Lenovo Legion 5 Plus. A series of posts by @moson was a great help to me in fixing it.

Here’s the procedure that worked for me:

With Ethernet connected, start pamac, the utility to install software, search for these packages (they will all be in AUR):


They should all be there. Install each of them in sequence (you might be able to check them all and apply the install at once, but I did each install individually in sequence)

Following the installs, do a full shutdown; boot (with Ethernet still attached); you should now see both the wired and wireless up and running; disconnect the Ethernet to test the wireless; the wireless should be working (you will, of course, have to log in to your router with your wireless password)!

Hope that helps.

  Device-1: Realtek
    vendor: Lenovo
    driver: rtw89_pci
      v: N/A
      modules: rtw89pci
    port: 2000
    bus-ID: 02:00.0
    chip-ID: 10ec:8852
    class-ID: 0280

1 Like